Java HTTP requests clobbers browser cookies causing session cookies to be lost

RESOLVED DUPLICATE of bug 526462

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 526462
9 years ago
9 years ago

People

(Reporter: Danny Thomas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4 (.NET CLR 3.5.30729)

There appears to be a regression related to the way cookies are handled w/ the Java plugin on 3.6b4. Blackboard Academic Suite CE/Vista has a Java applet based browser compatibility check. It makes HTTP requests for these checks and immediately after the check the application session is lost. Java console log output indicates that the request is made without a cookie, though a cookie is already set in the browser:

network: Connecting http://inter.blackboard.com:80/webct/urw/lc991.tp0/BrowserJVMChecker?PROVIDER=sun%20microsystems%20inc.&VERSION=1.6.x&EXTRAVERSIONINFO=1.6.0_17 with proxy=DIRECT
network: Connecting http://inter.blackboard.com:80/ with proxy=DIRECT
network: Server http://inter.blackboard.com:80/webct/urw/lc991.tp0/BrowserJVMChecker?PROVIDER=sun%20microsystems%20inc.&VERSION=1.6.x&EXTRAVERSIONINFO=1.6.0_17 requesting to set-cookie with "NSC_304724.qspe_wjq1=9fd66a8f3660;path=/"
network: Server http://inter.blackboard.com:80/webct/urw/lc991.tp0/BrowserJVMChecker?PROVIDER=sun%20microsystems%20inc.&VERSION=1.6.x&EXTRAVERSIONINFO=1.6.0_17 requesting to set-cookie with "JSESSIONIDVISTA=gnDWLyMBl8MNdNFCRcfnj0Sv46YBvyQKF1rMV1NxB2ycnsD2qTrv!-216525147!-779789121!80!-1!-2088635593!-779789120!80!-1; domain=.blackboard.com; path=/"

Repeated requests result in the same behaviour. Firefox 3.5 works perfectly on the same machine with the same Java version.

Reproducible: Always

Steps to Reproduce:
1. Go to http://inter.blackboard.com/, monitor the cookies set
2. Click browser checker while monitoring the Java console at trace level 2
3. Note that each subsequent browser checker activation causes the same behaviour
Actual Results:  
Set-Cookie header received from application server, browser cookie clobbered

Expected Results:  
Request has existing browser cookie
(Reporter)

Comment 1

9 years ago
I should also note that this can be reproduced on any instance of the application, it's not isolated to this environment.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526462

Comment 3

9 years ago
I really should have added a request that you check this again when the next beta/rc comes out in a few days time. thanx.
(Reporter)

Comment 4

9 years ago
Not sure how I missed that original issue; it's well described, maybe my search terms were off. In any case, beta 5 resolves the issue. Thanks John.
You need to log in before you can comment on or make changes to this bug.