windowState never changes back to STATE_NORMAL when window is maximized

RESOLVED DUPLICATE of bug 429954

Status

()

RESOLVED DUPLICATE of bug 429954
9 years ago
9 years ago

People

(Reporter: matthew.gertner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.98 KB, application/x-xpinstall
Details
(Reporter)

Description

9 years ago
I called window.maximize() on a chrome window, which causes it to be maximized as expected on Mac. However, even when the window is moved or resized after that, the windowState states set to STATE_MAXIMIZED and doesn't changed back to STATE_NORMAL as I expected.

Perhaps I am misunderstanding something, but on Windows this appears to work correctly.
Can you attach a testcase?
(Reporter)

Comment 2

9 years ago
Created attachment 420350 [details]
Test extension

This extension displays the value of windowState for the current chrome window in the status bar. "1" indicates that the window is maximized, "3" that it is normal. On Windows the value is displayed as expected. Maximize the window and it changes to "1". Resize after that and it returns to "3".

On Mac the value is initially "3". If you click on the green button to maximize, it stays on "3" (I would have expected it to change to "1"). If you call window.maximize() on the chrome window (you can do this by clicking on my status bar pane), it changes to "1" as expected. After that, it never changes back to "3" (even after restarting Firefox, as far as I can see).
What branch are you on? This works correctly for me on 3.7, but the bug that fixed it (bug 429954) should be on 3.6, too.
(Reporter)

Comment 4

9 years ago
I'm on 1.9.1. Sounds like this is a dupe then.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429954
You need to log in before you can comment on or make changes to this bug.