Update Flash version on Plugin Check page to 10.0.45

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: zzxc, Assigned: ozten)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
A new version of Flash has been released, so any versions older than 10.0 r42 (10.0.42.0) should trigger "update needed" status for Flash.  The page currently says "up to date" for the previous 10.0.32.0 version.
Assignee: nobody → ozten.bugs

Updated

9 years ago
Summary: Update Flash version on Plugin Check page to 10.0 r42 → Update Flash version on Plugin Check page to 10.0.42.34

Comment 1

9 years ago
Adobe released new version of Flash Player, 10.0.45.2
This should be fixed with r62195, and is waiting on IT bug 545918 to update the PFS2 database.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 545849
Depends on: 545918
Looks like this has been fixed in PFS2 and looks like it's working on the plugin check page.

$ curl -s 'http://pfs2.mozilla.org/?mimetype=application%2Fx-shockwave-flash&appID=%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D&appRelease=3.5.5&appVersion=20091102134505&clientOS=mac&chromeLocale=en-US' | prettyjson
[
    {
        "releases": {
            "others": [
                {
                    "status": "vulnerable", 
                    "app_release": "*", 
                    "os_name": "*", 
                    "vendor": "Adobe", 
                    "pfs_id": "adobe-flash-player", 
                    "url": "http://www.adobe.com/go/getflashplayer", 
                    "modified": "2010-02-17T03:44:42+00:00", 
                    "app_id": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}", 
                    "vulnerability_url": "http://www.adobe.com/support/security/bulletins/apsb09-10.html", 
                    "version": "9.0.159.0", 
                    "license_url": "http://www.adobe.com/go/eula_flashplayer", 
                    "relevance": 2, 
                    "locale": "*", 
                    "app_version": "*", 
                    "name": "Shockwave Flash"
                }, 
                {
                    "status": "vulnerable", 
                    "app_release": "*", 
                    "os_name": "*", 
                    "vendor": "Adobe", 
                    "pfs_id": "adobe-flash-player", 
                    "url": "http://www.adobe.com/go/getflashplayer", 
                    "modified": "2010-02-17T03:44:42+00:00", 
                    "app_id": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}", 
                    "vulnerability_url": "http://documents.iss.net/whitepapers/IBM_X-Force_WP_final.pdf", 
                    "version": "9.0.115.0", 
                    "license_url": "http://www.adobe.com/go/eula_flashplayer", 
                    "relevance": 2, 
                    "locale": "*", 
                    "app_version": "*", 
                    "name": "Shockwave Flash"
                }, 
                {
                    "status": "vulnerable", 
                    "app_release": "*", 
                    "os_name": "*", 
                    "vendor": "Adobe", 
                    "pfs_id": "adobe-flash-player", 
                    "url": "http://www.adobe.com/go/getflashplayer", 
                    "modified": "2010-02-17T03:44:42+00:00", 
                    "app_id": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}", 
                    "vulnerability_url": "http://www.adobe.com/support/security/bulletins/apsb09-10.html", 
                    "version": "10.0.22.87", 
                    "license_url": "http://www.adobe.com/go/eula_flashplayer", 
                    "relevance": 2, 
                    "locale": "*", 
                    "app_version": "*", 
                    "name": "Shockwave Flash"
                }
            ], 
            "latest": {
                "status": "latest", 
                "app_release": "*", 
                "app_version": "*", 
                "vendor": "Adobe", 
                "pfs_id": "adobe-flash-player", 
                "url": "http://www.adobe.com/go/getflashplayer", 
                "modified": "2010-02-17T03:44:42+00:00", 
                "app_id": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}", 
                "locale": "*", 
                "version": "10.0.45.0", 
                "license_url": "http://www.adobe.com/go/eula_flashplayer", 
                "relevance": 4, 
                "guid": "{89977581-9028-4be0-b151-7c4f9bcd3211}", 
                "xpi_location": "http://fpdownload.macromedia.com/get/flashplayer/xpi/current/flashplayer-mac.xpi", 
                "os_name": "mac", 
                "name": "Shockwave Flash"
            }
        }, 
        "aliases": {
            "regex": [
                ".*Flash.*"
            ], 
            "literal": [
                "Adobe Flash Player", 
                "Shockwave Flash"
            ]
        }
    }
]
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Summary: Update Flash version on Plugin Check page to 10.0.42.34 → Update Flash version on Plugin Check page to 10.0.45
Duplicate of this bug: 545799
Verified FIXED on http://www.mozilla.com/en-US/plugincheck/.
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.