[TXT]multi-lined select :hover fails when over any part of its own scroll bar

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: James Lariviere, Assigned: rods (gone))

Tracking

Trunk
Future
x86
Other
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
DESCRIPTION:

multi-lined select :hover fails when over any part of its own scroll bar.


STEPS TO REPRODUCE:

view test case.

ACTUAL RESULTS:

:hover works fine until your over any part of the scroll bar. Then it goes back
to the specified normal css specified rendering.

EXPECTED RESULTS:

multi lined select :hover should render when over any part of the select element.


DOES NOT WORK CORRECTLY ON:

Win98 build 2000091820 (9-18-00)
(Reporter)

Comment 1

18 years ago
Created attachment 15226 [details]
test case

Comment 2

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
Taking QA (CSS issue). This depends on 5693.

Hyatt: Once 5693 is refixed, will this magically work? Or will XBL widgets have
to be slapped to get :hover notifications propagated out to their parent?
Depends on: 5693
QA Contact: bsharma → py8ieh=bugzilla

Comment 4

18 years ago
not sure.  selects still use native scrollbars, and i have no idea what the code 
path is for that.
Oh, good point. We're going to be getting rid of those scrollbars soon, right?
e.g. when we move over to XBL selects? In that case we should mark this bug
dependent on the bug to move over to XBL widgets.

Comment 6

18 years ago
in either case we should set this bug to New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: multi-lined select :hover fails when over any part of its own scroll bar → [TXT]multi-lined select :hover fails when over any part of its own scroll bar
Target Milestone: --- → Future
(Reporter)

Comment 7

18 years ago
Now that the xbl controls have been hooked in... this bug reacts differently.

:hover only fires up when the pointer is in the select border.
:hover no longer fires up inside the select or over the scrollbars at all.

This behavior is similar to my report in 41819 for text inputs, textareas, etc.
Since bug 41819 encompasses many form elements, I'm just depending it instead of
duping it.

When 41819 gets fixed I think that this will get fixed I think.
Depends on: 41819
(Assignee)

Updated

17 years ago
Priority: P3 → --
(Reporter)

Comment 8

16 years ago
Nope I was wrong now that bug 5693 and 41819 (basically except the file picker)
have been fixed this bug still occurs.  Note that the when hovering over the
scrollbar in the multiselect DOES NOT trigger :hover.

Comment 9

15 years ago
:hover over the scroll bar is working for me on mozilla 1.3 linux except for one
vertical 1px line before the select's margin. Position the mouse pointer on the
right margin of the select and move it very slowly to the left, the :hover will
fail and then triggered again.
Native scrollbars are no more, and I can't reproduce the 1px thing.  Roc, you're
working on mouse events in this situation, right?  This bug should probably
depend on that one....

Comment 11

14 years ago
I cant't reproduce the 1px thing either and the :hover is fine for me on firefox
0.8 linux.
looks OK to me. Probably got fixed when native scrollbars were removed.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.