Closed Bug 535999 Opened 13 years ago Closed 12 years ago

Figure out what history.pushState should do when it's called early in the page's lifecycle

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 615501

People

(Reporter: justin.lebar+bug, Unassigned)

References

Details

What happens if history.pushState is called very early in a page's lifecycle?  Is it possible to call pushState before we've created a history entry for the current page?  In that case, it would be tricky to link the new history entry to the current one.

(See also comments 33 and 34 in bug 500328.)
Depends on: 500328
Blocks: 580066
No longer blocks: 580066
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 615501
Component: DOM: Other → DOM
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.