'WINNT 5.2 comm-central-trunk build' times out while running 'nss/shlibsign', due to missing renamed sqlite3.dll

VERIFIED FIXED in seamonkey2.1a1

Status

SeaMonkey
Build Config
--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: Robert Kaiser)

Tracking

({regression})

Trunk
seamonkey2.1a1
x86
Windows Server 2003
regression
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fixed by clobbering])

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey&maxdate=1261230389&hours=24&legend=0&norules=1
moz:d303e54445e7 was fine.
moz:eeba84d24038 went red because of bug 524944 landing.
moz:f6f1982d758d fixed that bustage. But this bug appeared.

Firefox, Thunderbird and 'WINNT 5.2 comm-central-trunk nightly' are green.

Maybe a stuck file/process? Or this tree needs a clobber? ...
(Assignee)

Comment 1

8 years ago
This must be a code failure - it happens on all machines, and actually started right _after_ I clobbered dist/ on them.
(Assignee)

Updated

8 years ago
Assignee: kairo → nobody
Component: Build Config → General
QA Contact: build-config → general
(Assignee)

Comment 2

8 years ago
And here's a good hint of what's up there - an error message shown on 3 of the 4 machines:

shlibsign.exe - Unable To Locate Component
The application has failed to start because sqlite3.dll was not found. Re-installing the application may fix this problem.
(Assignee)

Comment 3

8 years ago
Sounds to me like something else caused by bug 513747 but maybe hidden until we clobbered dist/ on the machines.

I completely clobbered objdir on the machines to be sure, but I think very much that this is related to the sqlite renaming.
Depends on: 513747
(Reporter)

Comment 4

8 years ago
["Mid-air collision detected!", posting anyway, ftr.]

(In reply to comment #0)

Regression timeframe:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d303e54445e7&tochange=f6f1982d758d
Nothing obvious to me. (but see below)

(In reply to comment #1)
> This must be a code failure - it happens on all machines, and actually started
> right _after_ I clobbered dist/ on them.

(Well, I couldn't guess that, as it's not noted on the waterfall...)
Maybe the clobber triggered this failure somehow:
if it's a code issue, it might be from an older changeset :-/
(Reporter)

Comment 5

8 years ago
(In reply to comment #3)

> Sounds to me like something else caused by bug 513747 but maybe hidden until we
> clobbered dist/ on the machines.

Maybe, yes.
It even looks like it could be related to bug 519550...

> I completely clobbered objdir on the machines to be sure, but I think very much
> that this is related to the sqlite renaming.

Worth trying, though I wonder why it fails on this tree only and nowhere else :-<
(I mean, at least Firefox does automatic clobber, doesn't it?)
Blocks: 513747
No longer depends on: 513747
Summary: 'WINNT 5.2 comm-central-trunk build' times out while running 'nss/shlibsign' → 'WINNT 5.2 comm-central-trunk build' times out while running 'nss/shlibsign', due to missing renamed sqlite3.dll
(Assignee)

Comment 6

8 years ago
Looks like the complete clobber of the objdir helped in the end, all machines came back green after all - and yes, I vaguely remember that Firefox needed a clobber there as well - I guess the Windows build chain has a problem finding out about changed dependencies...
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

8 years ago
Yeah, both bugs were pushed with a clobber:
see bug 513747 comment 87 for example.

V.Fixed, per tinderbox.
Assignee: nobody → kairo
No longer blocks: 513747
Status: RESOLVED → VERIFIED
Component: General → Build Config
Depends on: 513747
Flags: in-testsuite-
QA Contact: general → build-config
(Reporter)

Updated

8 years ago
Whiteboard: [Fixed by clobbering]
You need to log in before you can comment on or make changes to this bug.