Thunderbird hangs on Get Mail from a Mac.com/Me.com IMAP account when waking from sleep and using third-party (USB) WiFi adapter

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: nzervas, Unassigned)

Tracking

(Depends on: 1 bug, {hang})

1.9.2 Branch
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has protocol log] [gs][needs retest TB5], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: 3.0

For MacOS X 10.4.11 (PPC) and Thunderbird 3.0 (release):

Launch Thunderbird
Get Mail for a Mac.com/Me.com IMAP account.  All's well.
Sleep the Mac then wake the Mac...
Thunderbird will not resume Get Mail process for the Mac.com/Me.com IMAP account.
Must be Forced Quit and re-launched to resume Get Mail.

Reproducible: Always

Steps to Reproduce:
1. Launch Thunderbird 3.0
2. Sleep the Mac
3. Wake the Mac.
4. Wait... Thunderbird will not get new mail in the mac.com/me.com IMAP account.  

Actual Results:  
There is a small progress wheel attached to the cursor...
When quitting, get the spinning pinwheel... Must the Force Quit.

Expected Results:  
Expected a normal quit of the program.
Is the UI responding when you wake up from sleep ?

Does this happens if you start thunderbird in -safe-mode (http://kb.mozillazine.org/Safe_mode) ?

Are you using AutoSync (ie did you change any settings with autosync in them) ?

Could you produce a imap:5,ImapAutoSync:5 log file as described at https://wiki.mozilla.org/MailNews:Logging and attach it to the bug so we can try to analyze what is going on ?
(Reporter)

Comment 2

9 years ago
Does not happen in Safe mode.  Not autosyncing (turned this off in Migration Assistant).  Since you asked me to verify a few things, I can say now that this behavior does not happen for a short sleep (<1 minute) but only after several hours of sleeping.  Not sure how to make a log file that will capture a hang like this.  Thanks, NZ
When it doesn't happen in -safemode that means it's related to an extension, or a theme, could you list the extensions you are using ? and try to figure out which one is causing the issue ?
(Reporter)

Comment 4

9 years ago
No themes or extensions.  Here is end  imap.log:

<------------------------------------------>

46093824[164cb00]: ReadNextLine [stream=b988478 nb=43 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15892 FETCH (FLAGS (NonJunk) UID 21242)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=51 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15893 FETCH (FLAGS (\Answered \Seen) UID 21243)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=43 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15894 FETCH (FLAGS (NonJunk) UID 21244)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=41 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15895 FETCH (FLAGS (\Seen) UID 21245)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=43 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15896 FETCH (FLAGS (NonJunk) UID 21246)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=43 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15897 FETCH (FLAGS (NonJunk) UID 21247)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=49 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15898 FETCH (FLAGS (\Seen NonJunk) UID 21248)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=43 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15899 FETCH (FLAGS (NonJunk) UID 21249)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=43 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15900 FETCH (FLAGS (NonJunk) UID 21250)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=49 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: * 15901 FETCH (FLAGS (\Seen NonJunk) UID 21251)
46093824[164cb00]: ReadNextLine [stream=b988478 nb=16 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: 5 OK Completed
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:SendData: 6 IDLE
46093824[164cb00]: ReadNextLine [stream=b988478 nb=10 needmore=0]
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:CreateNewLineFromSocket: + idling
-1610551928[1607900]: 2e8e400:mercury.mclean.harvard.edu:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN
49815040[ef907d0]: ImapThreadMainLoop entering [this=2e8e400]
49815040[ef907d0]: 2e8e400:mercury.mclean.harvard.edu:NA:ProcessCurrentURL: entering
49815040[ef907d0]: 2e8e400:mercury.mclean.harvard.edu:NA:ProcessCurrentURL:imap://nzervas@mercury.mclean.harvard.edu:993/select%3E/INBOX:  = currentUrl
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:SendData: DONE
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:SendData: 7 logout
-1610551928[1607900]: 10a38000:mail.mac.com:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN
277102592[8b457c0]: ImapThreadMainLoop entering [this=10a38000]
277102592[8b457c0]: 10a38000:mail.mac.com:NA:ProcessCurrentURL: entering
277102592[8b457c0]: 10a38000:mail.mac.com:NA:ProcessCurrentURL:imap://nzervas@mail.mac.com:993/select%3E/INBOX:  = currentUrl
-1610551928[1607900]: 2c4ba00:imap.gmail.com:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN
46448128[ef947e0]: ImapThreadMainLoop entering [this=2c4ba00]
46448128[ef947e0]: 2c4ba00:imap.gmail.com:NA:ProcessCurrentURL: entering
46448128[ef947e0]: 2c4ba00:imap.gmail.com:NA:ProcessCurrentURL:imap://nzervas@imap.gmail.com:993/select%3E/INBOX:  = currentUrl
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:TellThreadToDie: close socket connection
46093824[164cb00]: ImapThreadMainLoop leaving [this=10838e00]

Updated

9 years ago
Keywords: hang
Whiteboard: [has protocol log]

Comment 5

9 years ago
bienvenu, want more than an imap log?

Comment 6

9 years ago
that log doesn't really help - we don't seem to be doing anything when we try to run the url:

2c4ba00:imap.gmail.com:NA:ProcessCurrentURL:imap://nzervas@imap.gmail.com:993/select%3E/INBOX:
 = currentUrl
46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:TellThreadToDie: close socket
connection
46093824[164cb00]: ImapThreadMainLoop leaving [this=10838e00]

We should re-trying, I guess, because the connection seems to be bad, but we're not, and I don't know why not...I suppose I could add logging to the retry code...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Depends on: 540763

Comment 7

9 years ago
xref Bug 494849 Freezing after wake from sleep [Mac]

Comment 8

8 years ago
bienvenu, so a hang tracktrace won't do the trick?  https://wiki.mozilla.org/Thunderbird:Testing:Get_A_Debug_Thunderbird_Hang_Stack

(In reply to comment #6)
> that log doesn't really help - we don't seem to be doing anything when we try
> to run the url:
> 
> 2c4ba00:imap.gmail.com:NA:ProcessCurrentURL:imap://nzervas@imap.gmail.com:993/select%3E/INBOX:
>  = currentUrl
> 46093824[164cb00]: 10838e00:mail.mac.com:S-INBOX:TellThreadToDie: close socket
> connection
> 46093824[164cb00]: ImapThreadMainLoop leaving [this=10838e00]
> 
> We should re-trying, I guess, because the connection seems to be bad, but we're
> not, and I don't know why not...I suppose I could add logging to the retry
> code...
(Reporter)

Comment 9

8 years ago
FWIW, only happens when eMac is using a third-party (USB) WiFi adapter.  Seems the wake time for the adapter stalls Thunderbird.  All better now that I have switched back to built-in Airport Extreme Card...

Updated

8 years ago
Whiteboard: [has protocol log] → [has protocol log] [gs]

Updated

8 years ago
Duplicate of this bug: 577663
Dan can you reproduce ?
I've added it to my todo list; not yet quite sure when I'll get a few mins, so if you find someone else, feel free to offer to them.  Adding Gary to the CC, in case he happens to still have a Mac and a bit time to poke at this...

Comment 13

7 years ago
I'd like to add that I've been having this problem for a while.  Just finally decided to file the bug, and realized there was an existing one.

I've had this issue, sporatically, for a 'long time' (TM).  And it seems to be with any IMAP account, not just a mac.com or me.com one.

If I sleep my laptop (mac book pro) for significant amounts of time (at least an hour, I'd say) ... by just shutting the lid.

Then open it up and start using it.  If I left Tbird running, there's a significant chance (25%? 50%?) that it may lock up.

When it does this, it will usually only be one account of the numerous I check that 'locks' and spins the beachball.  The rest of the accounts will be responsive.  (Even if they are on the same host).   Clicking 'get mail' won't help.

Sometimes, 30 minutes or an hour later if I ignore it, it fixes itself.  But rarely.

Usually I have to kill Thunderbird.  And then it won't really die, so I have to force quit it.

Upon restarting, it instantly downloads new mail happily.
Component: OS Integration → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: os-integration → networking.imap

Comment 14

7 years ago
Eli, are you also not using built-in Airport?
Summary: Thunderbird hangs on Get Mail from a Mac.com/Me.com IMAP account when waking from sleep. → Thunderbird hangs on Get Mail from a Mac.com/Me.com IMAP account when waking from sleep and using third-party (USB) WiFi adapter

Comment 15

7 years ago
Actually, I'm using the built in Wifi

Comment 16

7 years ago
(In reply to comment #15)
> Actually, I'm using the built in Wifi

on a Mac?  or not?

Comment 17

7 years ago
Yes, on a MacBook Pro 17" - First batch of the Unibody style from a couple years ago.

Comment 18

7 years ago
nzervas, eli, please retest with version 5 and report results. (or better yet, version 6 - http://www.mozilla.org/en-US/thunderbird/6.0beta/ )
Whiteboard: [has protocol log] [gs] → [has protocol log] [gs][needs retest TB5]
Version: unspecified → 1.9.2 Branch

Comment 19

7 years ago
nzervas has "abandoned Mac OS X 10.4 Tiger and am now using Mac OS X 10.6 Snow Leopard with a fully OEM iMac (no third-party WiFi).  All is fine now."
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.