many editor-oriented menu items/accelerators disabled when opening a file...

VERIFIED DUPLICATE of bug 71224

Status

()

Core
Editor
P3
blocker
VERIFIED DUPLICATE of bug 71224
18 years ago
17 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Charles Manske)

Tracking

({regression, smoketest})

Trunk
regression, smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
...from the Open Web Location dialog. see this using 2000.09.21.08 mozilla bits
on win98 (don't know if this occurs on other platforms). couldn't find a
recently-filed bug on this, but dup if one already exists.

to repro:
1. bring up the Open Web Location dialog (ctrl+L or File > Open Web Location).
2. select New Composer Window from the droplist.
3. either enter a URL in the textfield (eg, http://www.iwaruna.com/), or click
the Choose File button to load a local file.
4. click Open button and a new editor window appears displaying the file contents.
5. do some editing (or not).
6. try to save the file or close the window by either ctrl+S/ctrl+W or selecting
said items from the File menu.

result: you can't. (workaround is to click the X close box in the titlebar,
which will prompt you for saving, but...) in fact, most of the File menu, all of
the Edit and Inser menu items are greyed-out and thus inaccessable.
(Reporter)

Comment 1

18 years ago
regression, pls fix by beta3.
Keywords: nsbeta3, regression

Comment 2

18 years ago
Dup, I think. sujar, charley -- know the bug# ?
(Reporter)

Comment 3

18 years ago
decklin says this is not a problem on linux. beppe, have you seen this before,
since you run win98?
(Assignee)

Comment 4

18 years ago
I don't see any bug on Windows NT. After opening a file, Save, Save As , Revert
items are disabled correctly -- there are not changes in document.
Afte typing, all these items are enabled correctly.

Comment 5

18 years ago
i've been using today's build on win98 and I don't see this -- in fact I've
saved several pages today.

Comment 6

18 years ago
marking wfm -- Sarah if you see this happen on 9/22  build, call me
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

18 years ago
verified in 9/22 build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

18 years ago
very annoying --i can get this to happen using 2000.10.16.09-n6 commercial
branch bits on linux. reopening. unable to repro on winnt or mac [same build
time]. very weird!
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 9

18 years ago
Sairuh--I'm running the same build (commerical N6 from 10/16) on Linux (RedHat
6.2).  I don't see this problem.  Note:  Control-S will be disabled if you
haven't made any changes to the file.

Is the caret blinking in the text when you see this bug?  If not, then there is
another bug for edit area not having focus.  
(Reporter)

Comment 10

18 years ago
dang, i tried to reproduce this (using the same bits as my last comment, on
linux), but couldn't! it might be something i'm doing in the browser before i
open an editor window. *shrug*

marking wfm.

in any case, when i had seen it y'day, i clicked in the content window to give
it focus, the menu items didn't become active...
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
verified in 10/18 build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

18 years ago
reopening. this is still happening for me. nominating for beta1.

using 2001.03.12.12 opt commercial bits on linux.

1. start browser [i used an existing profile].
2. from the browser window, select either Tasks > Navigator, or File > Edit
Page.

observe: in the resulting editor window, most of the menu items, buttons and
accelerators are disabled.

workaround: launching ./netscape -edit from the command line, this problem
doesn't crop up with the resulting editor window.
Status: VERIFIED → REOPENED
Keywords: nsbeta3 → nsbeta1
OS: Windows 98 → Linux
Resolution: WORKSFORME → ---
(Reporter)

Comment 13

18 years ago
oopsey, typo: in step 2 in my last comment, i meant to say Tasks > Composer.

Comment 14

18 years ago
does the composer window have focus when it is first displayed? if not, then 
this is a focus issue
(Assignee)

Comment 15

18 years ago
Sounds like bug 71426. What URL are you trying to edit?
(Reporter)

Comment 16

18 years ago
beppe: the composition area has focus when i bring up the editor window.

charley: this occurred for a blank editor window [Tasks > Composer], as well as
the current page i was trying to edit [selecting File > Edit Page while viewing
http://bugzilla.mozilla.org/].

another observation: once i start typing in the composition area, the buttons,
menu items and accelerators become enabled.

Comment 17

18 years ago
hmm -- I see this as well when I am editing a document on win98. If I select 
save, the buttons are disabled, if I then select somewhere in the document, they 
remain disabled. They only get enabled after I type in text.

Charley, assigning this one over to you
Assignee: beppe → cmanske
Status: REOPENED → NEW
(Reporter)

Comment 18

18 years ago
->all, since it's been seen on linux and win98... however, for some odd reason i
cannot repro this on Mac [2001.03.12.11 comm].
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 19

18 years ago
This is too confusing -- shouldn't have reopenned previous bug. I don't see a
reproduceable description of the problem that I can test.
Please clarify.
(Reporter)

Comment 20

18 years ago
charley, try these steps --preferably on *both* linux and win98:

1. start your browser --go to http://bugzilla.mozilla.org/
2. select *either* Tasks > Composer OR File > Edit Page

result: the resulting editor page will have many disabled buttons, menu items
and accelerators *until* you start typing in the composition area. in addition,
focus will initially be in the composition area.
(Assignee)

Comment 21

18 years ago
Described step don't show any bad symptoms on NT4.

Comment 22

18 years ago
bet my 20$ ..this is bug 71224 !! PPls confirm and mark this puppy a dup...

Comment 23

18 years ago
*** Bug 71224 has been marked as a duplicate of this bug. ***

Comment 24

18 years ago
I see this on my Macintosh build today.  :-(
Major blocker.  I can't save, I can't quit, I can't insert html elements...
Severity: major → blocker
Keywords: smoketest

Comment 25

18 years ago
I don't think this bug should have been reopened for this smoketest blocker. 
The problem now is more basic and less difficult to reproduce than this bug was
(as originally reported). This bug was originally reported against the problem
that Edit Page would not allow saving.  This bug is simply that the composer
(with a new file or edit page) has most of it's buttons disabled and many of the
Menu Items disabled as well.  I suspect that this is not the same failure that
was reported 6 months ago (this bug was reported before the MN6 Netscape RTM
branch).

Comment 26

18 years ago
i *absolutely* agree with Asa..let this bug rest in peace!! marking this as a 
dup..

*** This bug has been marked as a duplicate of 71224 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 27

18 years ago
okay, vrfy.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.