Closed Bug 536355 Opened 10 years ago Closed 10 years ago

Text characters not rotated in child element of -moz-transform: rotate

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 518172

People

(Reporter: robertc, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091221 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091221 Minefield/3.7a1pre

Individual characters are sometimes not rotated when they are part of an element which has a -moz-transform: rotate - they are drawn in the correct place but their orientation does not reflect the transform.  In the case of statically rotated elements the characters can be reset by scrolling the element out of the viewport and back.  If you have an element which does a rotate dynamically (in my example page it's on :hover) then the text sometimes appears OK and sometimes doesn't.

Reproducible: Sometimes

Steps to Reproduce:
1. Load example page
2. Refresh or mouse over an element which responds to :hover until problem appears

Actual Results:  
Characters themselves are not rotated.

Expected Results:  
Everything rotated.

Seems to work fine in 3.6 beta.
If I scroll down a line using the scroll arrow the characters are rotated; If I down scroll a page the characters below the previous page bottom are not rotated.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.3a1pre) Gecko/20091221 Minefield/3.7a1pre ID:20091221052153
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Duplicate of bug 518172?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 518172
You need to log in before you can comment on or make changes to this bug.