Closed Bug 53637 Opened 19 years ago Closed 19 years ago

If CreateDefaultProfile fails, the app quits silently on startup

Categories

(SeaMonkey :: Startup & Profiles, defect, P3)

All
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 19434
mozilla0.9

People

(Reporter: rubydoo123, Assigned: ccarlen)

Details

Mozilla is simply quitting on launch, when I try to run it under Mac OS X (in 
the Blue Box).
Some debugging shows that the profile->StartupWithArgs returns an error, because 
CreateDefault profile fails.

You need to show an error dialog of some kind if this sort of failure occurs. I 
already reported this kind of bug on profile, and now it's reared it's head 
again.
Not a migration bug.  Reassigning to Profile Manager.
Assignee: dbragg → racham
Component: Profile Migration → Profile Manager FrontEnd
Doing a mass reassign to Conrad Carlen.

Conrad is going address all current and upcoming profile manager issues. Please
do not hesitate to involve me in any of the issues.
Assignee: racham → ccarlen
Will look at it when I get an OS X installation. First of all, what's causing
CreateDefaultProfile needs to be dealt with. The fact that it quits silently if
StartupWithArgs returns an error is bug 19434.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.8
Blocks: 64833
No longer blocks: 64833
-> mozilla0.9
Target Milestone: mozilla0.8 → mozilla0.9

*** This bug has been marked as a duplicate of 19434 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
verify
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.