mochitest thebes crashtests: "<Error> doClip: empty path." followed by a hang (after 385228-1.svg)

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Core
Graphics
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: Benjamin Smedberg, Assigned: longsonr)

Tracking

({intermittent-failure, regression})

Trunk
mozilla1.9.3a1
x86
Mac OS X
intermittent-failure, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Two mac boxes both failed the same way:
REFTEST TEST-PASS | file:///builds/moz2_slave/mozilla-central-macosx-opt-unittest-everythingelse/build/reftest/tests/gfx/thebes/crashtests/385289-1.xhtml | (LOAD ONLY)
Tue Dec 22 05:42:33 bm-xserve18.build.mozilla.org firefox-bin[578] <Error>: doClip: empty path.
Tue Dec 22 05:42:33 bm-xserve18.build.mozilla.org firefox-bin[578] <Error>: doClip: empty path.
Tue Dec 22 05:42:34 bm-xserve18.build.mozilla.org firefox-bin[578] <Error>: doClip: empty path.
Tue Dec 22 05:42:34 bm-xserve18.build.mozilla.org firefox-bin[578] <Error>: doClip: empty path.
REFTEST TEST-PASS | file:///builds/moz2_slave/mozilla-central-macosx-opt-unittest-everythingelse/build/reftest/tests/gfx/thebes/crashtests/385228-1.svg | (LOAD ONLY)
TEST-UNEXPECTED-FAIL | automation.py | application timed out after 330 seconds with no output

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261488712.1261490745.15756.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/12/22 05:31:52

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261492205.1261494286.25334.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/12/22 06:30:05
Before that:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261452944.1261455055.7615.gz#err2
OS X 10.5.2 mozilla-central test everythingelse on 2009/12/21 19:35:44
s: bm-xserve17

After that:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261520146.1261522720.22986.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/12/22 14:15:46
s: bm-xserve18

Way way before that:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261243023.1261245024.29438.gz#err1
OS X 10.5.2 mozilla-central test everythingelse on 2009/12/19 09:17:03
s: bm-xserve18

Which was actually the run from when the cursed patch for bug 510177 landed the first time.
Blocks: 510177
Keywords: regression
Summary: mochitest thebes crashtests: "<Error> doClip: empty path." followed by a hang → mochitest thebes crashtests: "<Error> doClip: empty path." followed by a hang (after 385228-1.svg)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261521767.1261525725.24894.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/12/22 14:42:47
s: bm-xserve19
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261525899.1261530233.10785.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/12/22 15:51:39
s: bm-xserve17
(Assignee)

Comment 4

9 years ago
On windows at least the code that changed in bug 510177 is not executed during display of 385228-1.svg having said that 385228-1.svg and 385228-2.svg have only ever caused issues on Macs and I don't have one of those.

Even though Windows doesn't crash it does create a huge surface so I'll look into whether that is legitimate and if not fix it or if so limit the size further.
(Assignee)

Comment 5

9 years ago
I think doClip: empty path must be coming from the Mac kernel as I can't find a match using MXR

Comment 6

9 years ago
http://www.google.com/search?q=doClip%3A%20empty&ie=utf-8&oe=utf-8

Google says it happens to lots of OS X apps and that no one has any useful fixes.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261538348.1261540297.26617.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/12/22 19:19:08
s: bm-xserve19
(Assignee)

Comment 8

9 years ago
Created attachment 418985 [details] [diff] [review]
patch

I assume this will fix it since we're clearly just at the boundary currently with the random orange.
Attachment #418985 - Flags: review?(roc)
Actually, how about changing it to 4096?
(Assignee)

Comment 10

9 years ago
Created attachment 419050 [details] [diff] [review]
patch
[Checkin: Comment 11]

Sure
Attachment #418985 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Whiteboard: [orange] → [orange][needs landing]
Comment on attachment 419050 [details] [diff] [review]
patch
[Checkin: Comment 11]


http://hg.mozilla.org/mozilla-central/rev/be1bef87f407
Attachment #419050 - Attachment description: patch → patch [Checkin: Comment 11]
Assignee: nobody → longsonr
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [orange][needs landing] → [orange]
Target Milestone: --- → mozilla1.9.3a1
(Assignee)

Updated

9 years ago
Blocks: 545522

Updated

8 years ago
Blocks: 438871
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.