Last Comment Bug 536704 - auto sending return receipts does not work
: auto sending return receipts does not work
Status: RESOLVED FIXED
: fixed-seamonkey2.0.3, regression
Product: MailNews Core
Classification: Components
Component: Composition (show other bugs)
: unspecified
: All All
: -- minor (vote)
: Thunderbird 3.1a1
Assigned To: Michiel van Leeuwen (email: mvl+moz@)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-24 13:38 PST by Michiel van Leeuwen (email: mvl+moz@)
Modified: 2010-02-05 15:14 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
.1-fixed


Attachments
patch (523 bytes, patch)
2009-12-24 13:42 PST, Michiel van Leeuwen (email: mvl+moz@)
mozilla: review+
mozilla: superreview+
standard8: approval‑thunderbird3.0.1+
Details | Diff | Review

Description Michiel van Leeuwen (email: mvl+moz@) 2009-12-24 13:38:21 PST
From code inspection:
http://mxr.mozilla.org/comm-central/source/mailnews/extensions/mdn/src/nsMsgMdnGenerator.cpp#362
The receipt will only be send automatically if (1) the return path is empty, and (2) it is equal to the address the receipt should be sent to.
Obviously, both can not hold a the same time. This seems like a conversion error: http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/mailnews/extensions/mdn/src&command=DIFF_FRAMESET&file=nsMsgMdnGenerator.cpp&rev2=1.21&rev1=1.20 around line 371. The check should be reversed.

Now, I can't test this bug, because my server messes with the return path. So it will never match for me anyway. And I don't know if this should be fixed at all. People might have unknowingly set the pref to autosend, but still got asked to send, because of this bug.
Comment 1 Michiel van Leeuwen (email: mvl+moz@) 2009-12-24 13:42:21 PST
Created attachment 419143 [details] [diff] [review]
patch

This patch should fix it. But see my remarks in comment 0
Comment 2 David :Bienvenu 2009-12-30 11:02:01 PST
this bug was almost certainly introduced in 3.0 so I think fixing it is the right thing to do. Thx for the patch.
Comment 3 David :Bienvenu 2009-12-30 11:28:50 PST
Comment on attachment 419143 [details] [diff] [review]
patch

this does fix the problem for me.
Comment 4 David :Bienvenu 2009-12-30 11:29:16 PST
We've had several reports of this...
Comment 5 Mark Banner (:standard8) 2010-01-06 07:47:37 PST
I pushed this to trunk so we can get a little baking time before we want it on branch:

http://hg.mozilla.org/comm-central/rev/9659ba5295e6
Comment 6 Mark Banner (:standard8) 2010-01-09 02:56:11 PST
Patch checked into 3.0.1pre in time for 3.0.1:

http://hg.mozilla.org/releases/comm-1.9.1/rev/b6bf325fc693

Note You need to log in before you can comment on or make changes to this bug.