Closed Bug 536715 Opened 10 years ago Closed 10 years ago

Adobe Flash Player for 64 bit O/S will not work for minefield but it works for Firefox

Categories

(Firefox :: General, defect, blocker)

x86_64
Windows 7
defect
Not set
blocker

Tracking

()

RESOLVED INVALID

People

(Reporter: contactwilliamjones, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1 x64; en-US; rv:1.9.3a1pre) Gecko/20091116 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1 x64; en-US; rv:1.9.3a1pre) Gecko/20091116 Minefield/3.7a1pre

Attempted to load the prerelease adobe flash-player for 64 bit O/s and it installed for Firefox's newest release but will not install in minefield

Reproducible: Always

Steps to Reproduce:
1. go to any website that uses adobe flash player while using minefield
2. click to install plugin
3. follow manual steps to install the prerelease flash player for 64 bit O/S and then try it again
4. Now try it with Firefox and all is well
Actual Results:  
Flash Palyer plugin still not working for minefield but working for Firefox

Expected Results:  
exactly what happened

should have accepted the plugin
So, if you go into about:plugins in minefield it is not displayed?
(In reply to comment #1)
> So, if you go into about:plugins in minefield it is not displayed?

It is not showing, it did not install either using the automatic or the manual method
This actually affects all of the 64 bit distros of Firefox at the present time.  Adobe just updated flash to a brand new version of 10.  The flash plugin that came originally with Nomoroka and Minefield no longer works due to the Adobe Flash Player update.  The 64 bit plugin for Firefox needs to be updated PRONTO!  Selecting the automated Plugin Installation results in the 32 bit plugin being installed and that doesn't work with this new 64 bit system.  So we need the 64 bit Adobe Flash plugin for Firefox (Minefield) sent out to us folks using 64 bit Firefox browsers.
Hi William,
are you sure you were actually able to install a 64 bit version of Flash?
AFAIK there is only a Linux version of it (http://labs.adobe.com/technologies/flashplayer10/64bit.html).
What you probably installed is the 32 bit version of Flash and you get the message that Flash 32 bit can't work on a 64 bit browser.

BTW you can now try the latest 64 bit version being built every day in here:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-3.7a5pre.en-US.win64-x86_64.zip
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-3.7a5pre.en-US.win64-x86_64.installer.exe
(Not that you won't hit the same problem)

For reference:
http://kb2.adobe.com/cps/000/6b3af6c9.html

(In reply to comment #0)
> Actual Results:  
> Flash Palyer plugin still not working for minefield but working for Firefox
> 
What do you mean that it does not work for Minefield but it does work for Firefox?
Remember that we have not been doing any 64 bit releases of Firefox and our plan is to do 64 bit releases later this year.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have not seen any other bug covering the lack of Flash for the 64 bit version for Firefox so I am raising the importance of this one and asking for blocking the next release.
Severity: normal → blocker
blocking2.0: --- → ?
Is it possible to use 32-bit plugins by running them in a separate plugin-container.exe process?
That's one of the applications of IPC - although I imagine the plugin-container.exe would have to be a 32-bit process, and I don't know if all the IPC code is pointer size agnostic (not that I've made an effort to look, mind you).
OK, when I first reported this bug it was when minefield was still in testing as well as the 64bit Adobe flash player. I have no issues any longer, the flash player works fine.
(In reply to comment #8)
> OK, when I first reported this bug it was when minefield was still in testing
> as well as the 64bit Adobe flash player. I have no issues any longer, the flash
> player works fine.

Where did you get the 64-bit Flash player? Did they release an alpha and they don't offer it anymore? Do you think you might still have a copy of it on your disk?

For reference:
http://kb2.adobe.com/cps/000/6b3af6c9.html
Version: unspecified → Trunk
Armen, I see William writes about 64bit Windows 7 OS, I only see a couple of references to x64 and flash under the OOPP bug.  Also since William uses Firefox and Minefield at the time this bug was filed, I can assume he didn't have a 64bit version then. 

I haven't heard of the 64bit OS folks needing to install 64bit flash on windows either and some are starting to test on the mozillazine nightly thread.

It appears this bug is just a case of a flash installer 32bit didn't recognize installing into 32bit Minefield (ie didn't recognize it by UA or Firefox Brand, or Release).

We can currently install 10.1.53.64 in 32bit flash in Minefield just fine now, but before I don't think it was possible.
Should we file then a separate bug for the 64-bit builds not having a Flash version to install?

On mozillazine I see users commenting [1] that there is no flash for 64-bit builds and that is my same experience when I tried to install Flash on the 64-bit build.

[1] http://forums.mozillazine.org/viewtopic.php?p=9441761#p9441761
(In reply to comment #11)
> Should we file then a separate bug for the 64-bit builds not having a Flash
> version to install?
> 
> On mozillazine I see users commenting [1] that there is no flash for 64-bit
> builds and that is my same experience when I tried to install Flash on the
> 64-bit build.
> 
> [1] http://forums.mozillazine.org/viewtopic.php?p=9441761#p9441761

I think that might be a good idea in the long run.
I am not sure if the flash player that I am using now is 64 bit or not but I do know this. I have windows 7 64bit. I downloaded minefield in the trial version and I downloaded the trial version of the flash player for 64bit systems. the flash player worked in my Firefox and in IE but not in Minefield. I now have the updated general release of Minefield and I have no flash player issues at all.
The flash player I had installed was a pre-release version of their future 64 bit player. At least that was what Adobe's site said. I can not find where they are offering it now so I am not sure now if it is a 64 bit player.
Most likely it is their 32 bit player that is now capable of working with Minefield.
As far as I am concerned this bug I reported is no longer a bug because I have no more issues.
I suggest starting a new thread for any other problems.
OK
No longer blocks: tracking_win64
Status: NEW → RESOLVED
blocking2.0: ? → ---
Closed: 10 years ago
Resolution: --- → INVALID
I have filed bug 570133 in case any of you want to follow the lack of Flash for the Windows 64-bit builds.
You need to log in before you can comment on or make changes to this bug.