"ASSERTION: not in child list", "ASSERTION: unexpected child list"

RESOLVED FIXED in mozilla2.0b1

Status

()

--
critical
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: jruderman, Assigned: mats)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
mozilla2.0b1
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Created attachment 419153 [details]
testcase

###!!! ASSERTION: not in child list: 'found', file layout/base/nsLayoutUtils.cpp, line 268

###!!! ASSERTION: unexpected child list: 'Error', file layout/generic/nsBlockFrame.cpp, line 4968
(Reporter)

Comment 1

9 years ago
Bug 540760 is probably related.
(Reporter)

Comment 2

8 years ago
This is annoying because it can trigger many different assertions down the road.
(Reporter)

Comment 3

8 years ago
How bad are these assertions?
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
I think Mats has dealt with some bugs with menupopups before.
(Assignee)

Comment 5

8 years ago
A few more assertions when reloading the testcase:

ARNING: Unable to test style tree integrity -- no content node: file layout/base/nsCSSFrameConstructor.cpp, line 8070
###!!! ASSERTION: style context has old rule node: 'n == mRuleTree', file layout/style/nsStyleSet.cpp, line 170
###!!! ASSERTION: old rule tree still referenced: 'Not Reached', file layout/style/nsStyleSet.cpp, line 1127
WARNING: NS_ENSURE_TRUE(aContent->GetDocument()) failed: file layout/base/nsCSSFrameConstructor.cpp, line 9094
###!!! ASSERTION: Have parent context and shouldn't: 'Error', file layout/base/nsFrameManager.cpp, line 621
frame: MenuPopup(menupopup)(-1) (0x431cb40) style: 0x431c978 {}
Has parent context:  style: 0x438e5c8 {}
Should be null
(Assignee)

Comment 6

8 years ago
It's a regression from http://hg.mozilla.org/mozilla-central/rev/912c5206ca3e
(the old code wasn't entirely correct either though)
Blocks: 508473, 540760
Severity: normal → critical
Keywords: regression
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 7

8 years ago
Created attachment 451189 [details] [diff] [review]
Patch rev. 1

Looks like a typo.  Don't use popupList if that list is actually empty.
Assignee: nobody → matspal
Attachment #451189 - Flags: review?(fantasai.bugs)
(Assignee)

Comment 8

8 years ago
Created attachment 451315 [details] [diff] [review]
Patch rev. 2

Added crash test for bug 572003.
Attachment #451189 - Attachment is obsolete: true
Attachment #451315 - Flags: review?(fantasai.bugs)
Attachment #451189 - Flags: review?(fantasai.bugs)
(Assignee)

Updated

8 years ago
Blocks: 572003

Comment 9

8 years ago
Comment on attachment 451315 [details] [diff] [review]
Patch rev. 2

Didn't review the tests, but the patch makes sense.
Attachment #451315 - Flags: review?(fantasai.bugs) → review+
(Assignee)

Comment 10

8 years ago
http://hg.mozilla.org/mozilla-central/rev/a981e599a748
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a6
Created attachment 454976 [details] [diff] [review]
slightly better documentation

When reading this patch, I thought it would be nice to clarify what GetChildListNameFor is for.  (In particular, it's not useful for figuring out where to insert a frame.)
Attachment #454976 - Flags: review?(matspal)
(Assignee)

Updated

8 years ago
Attachment #454976 - Flags: review?(matspal) → review+
blocking2.0: ? → final+
You need to log in before you can comment on or make changes to this bug.