If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fuori Orario website renders badly

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Italian
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: Francesco Lo Sapio, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.9.2b6pre) Gecko/20091228 Namoroka/3.6b6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.9.2b6pre) Gecko/20091228 Namoroka/3.6b6pre

Looks like the top menu of the website renders without stylesheets.

Reproducible: Always

Steps to Reproduce:
1. Open www.arcifuori.it
2.
3.
Actual Results:  
the layout renders badly


The behaviour is correct with Firefox 3.5.x and with others browsers 
(down to IE 6)
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
Confirmed with latest trunk on Windows Vista.

Regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1f823d3b7fbf&tochange=5c913c4662d8
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
Version: 3.6 Branch → 1.9.2 Branch
The problem is shown by:

Warning: Error in parsing value for 'background'.  Declaration dropped.
Source File: http://www.arcifuori.it/_2009/css_main.asp?IDTemaDaCaricare=27&TabellaToLoad=tbltemisiti&IDSito=2&IDRND=99&CL=
Line: 338

because about 20 lines in in that style sheet there is:

div#footer{background: #FFFFFF url(../thumbnail.aspx?img=images/temi/testate/&W=&H=; color: }/*#FFF*/

which is missing a close parenthesis.  We now follow the spec and search for that close parenthesis correctly.
Assignee: nobody → italian
Blocks: 476856
Component: Style System (CSS) → Italian
Product: Core → Tech Evangelism
QA Contact: style-system → italian
Version: 1.9.2 Branch → unspecified
(Reporter)

Comment 3

8 years ago
I sent an email to the webmaster to report the problem.
Let's see if he answers..

Comment 4

8 years ago
So it seems that firefox tries it's best to render this page, but with the css malformed so early in the file, you only see some UL > LI elements, and can roll over some rollovers.

Ria: were you able to render this page correctly with a build "pre-regression"?

This seems like RESOLVED->INVALID
(Reporter)

Comment 5

8 years ago
The webmaster has fixed the bug and now the website is ok.
Sorry if I misused bugzilla to report this kind of problem
Thanks

Comment 6

8 years ago
Sounds like RESOLVED FIXED to me, then. Francesco, this is *exactly* the sort of thing that the TE component is for, so feel free to file more bugs if you're so effective at getting them fixed :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.