Firefox downloading CSS unnecessarily for other media types

RESOLVED DUPLICATE of bug 79021

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 79021
8 years ago
8 years ago

People

(Reporter: ha, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.6) Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6 FirePHP/0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.6) Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6 FirePHP/0.3

It appears Firefox downloads all media style sheets, even if they do not apply. For example, if you have a separate style sheet for handhelds:

<link href="/css/handheld-stylesheet.css" media="handheld" rel="stylesheet" type="text/css" />

Firefox will still download this file and any imports within it:

@import url(handheld/stylesheet.css);

It is causing unnecessary HTTP requests and downloading. Granted, once it's loaded, it *should* be cached, although isn't it a bit unnecessary, or am I missing something?

Reproducible: Always

Steps to Reproduce:
Load a page that has a separate style sheet for the "handheld" CSS media profile, for example.


Actual Results:  
Watch Firefox (ie. with Firebug) download this style sheet and any @imports within this style sheet.

Expected Results:  
Firefox should ignore style sheets that it doesn't plan to apply (perhaps it should even ignore the "print" style sheet until you are actually about to print?).
Component: General → Style System (CSS)
OS: Linux → All
Product: Firefox → Core
QA Contact: general → style-system
Hardware: x86 → All
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 79021
You need to log in before you can comment on or make changes to this bug.