"ASSERTION: Our frame tree is likely to be bogus!" with xbl, xul:listcell

RESOLVED WORKSFORME

Status

()

Core
XBL
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

427 bytes, application/xhtml+xml
Details
(Reporter)

Description

8 years ago
Created attachment 420247 [details]
testcase

###!!! ASSERTION: Must have parent here: 'aContent->GetParent()', file layout/base/nsCSSFrameConstructor.cpp, line 4550

###!!! ASSERTION: Reparenting something that has no usable parent? Shouldn't happen!: 'Not Reached', file layout/base/nsFrameManager.cpp, line 792

###!!! ASSERTION: Our frame tree is likely to be bogus!: '!(styleChange & nsChangeHint_ReconstructFrame)', file layout/base/nsFrameManager.cpp, line 864
The good news is that I don't see any of these asserts in my build.  I bet money, based on examination of the testcas, that the second patch for bug 514300 fixes this.  I can verify by locally qpopping if desired...
Depends on: 514300
The fix for bug 514300 should have fixed this.  Jesse, can you retest?

If it's fixed, do we want to just push the testcase, or wait until we get bug 514300 on branches?
(Reporter)

Comment 3

8 years ago
I can't reproduce even at rev 50a66336ba73, before that fix landed.  So something else must have fixed this testcase.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Group: core-security → core-security-release
Group: core-security-release
You need to log in before you can comment on or make changes to this bug.