font fullnames (e.g. Arial Bold) are matched incorrectly as font family names

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: jtd, Assigned: jfkthame)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Under Windows we match "Arial Bold" to Arial, rather than using the fallback font.  This is an artefact of GDI which allows either in lookups.

Steps:

1. Load URL

Result: some red entries appear in Arial

Expected result: black enteries appear in Arial, red in Georgia

Firefox matches IE, it maps Arial Bold to Arial but doesn't draw using the bold face.  One might argue "meh, good enough" but this is completely inconsistent with the behavior on other platforms.

Note: inconsistencies in other browsers

Opera10/Mac: matches Arial Bold to the bold face of Arial
Opera10/Win: does not match Arial Bold

Webkit/Mac: matches Postscript name Arial-BoldMT to bold face of Arial but does not match Arial Bold
Webkit/Win: matches Arial Bold to the bold face of Arial but does not match Arial-BoldMT

(Webkit = Safari4/Chrome4)
(Assignee)

Comment 1

9 years ago
Your testcase works as intended for me using a build that includes (updated versions of) patches from bugs 493280 and 502906. (The significant one would be bug 493280.) Marking this as dependent.
Depends on: 493280
(Assignee)

Comment 2

9 years ago
Created attachment 421287 [details] [diff] [review]
collection of reftests based on the Arial testcase

Here are a group of reftests based on the original testcase, split into sections to make it easier to pinpoint failures.

It's difficult to test this stuff with 100% certainty, in the absence of a known, controlled collection of installed fonts, but these tests ought to detect the incorrect behavior on typical Mac and Windows systems, at least.

If Arial fonts are not installed at all (e.g. on Linux systems, perhaps?), the tests are intended to pass harmlessly, simply using generic fonts. Checking with tryserver to confirm this behavior.
Assignee: nobody → jfkthame
Attachment #421287 - Flags: review?(jdaggett)
(Reporter)

Comment 3

9 years ago
Comment on attachment 421287 [details] [diff] [review]
collection of reftests based on the Arial testcase

Looks good but I would use only the family names Arial and Georgia (with this casing, not quoted) in the ref pages.
Attachment #421287 - Flags: review?(jdaggett) → review+
(Assignee)

Comment 4

9 years ago
http://hg.mozilla.org/mozilla-central/rev/2b6846eef536
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.