'Set as New bookmark folder' menuitem doesn't work - JS error

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: cmaximus, Assigned: mozilla)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fix in hand][rtm+])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
***Overview Description: 

  The "Set as default bookmark folder" menuitem does not work. The command
works fine from the context-menu command.
...
As it turns out this whole class of meneitems don't work and produce the same
error:

"Set as New Bookmark Folder"
"Set as New Internet Search Folder"
"Set as Personal Toolbar Folder"

Javascript Error:
 line 0: NC is not defined

***Steps to Reproduce: 

1) Open Manage Bookmarks (Bookmarks| Manage Bookmarks)

2) Open the toplevel View menu.

3) Select any one of the 3 choices mentioned above.


***Actual Results: 

Same JS error as cited above.

***Expected Results: 

As per the name of each item the selected folder should be blessed as the new
default for each type of bookmark.

***Build Date & Platform Info: 

All platforms with the 2000092313 builds

***Additional Information:

I think this is a recent regression that showed up around the builds of 9/19 or so.

While these are technically 3 different menuitems it is the same bug with each
yielding the same error, so they will travel together. This bug shouldn't be marked
fixed and won't be verified as such until and unless all three items are fixed.
(Reporter)

Comment 1

18 years ago
adding keywords, here's to hoping this is an easy fix we can slide in for rtm.
Keywords: regression, rtm
(Assignee)

Comment 2

18 years ago
Created attachment 15361 [details] [diff] [review]
Trivial patch to use correct JS variable for namespace
(Assignee)

Comment 3

18 years ago
I've attached a simple fix.
Whiteboard: [fix in hand]
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Keywords: correctness
Priority: P3 → P1
Whiteboard: [fix in hand] → [fix in hand][rtm+]

Comment 4

18 years ago
Upgrading to P1 and marking this "rtm+".  (Hope this OK with dveditz.)
(Reporter)

Comment 5

18 years ago
*** Bug 53841 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
looks good! r=waterson
(Assignee)

Comment 8

18 years ago
Fix checked into both tip and branch.

Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
The problem described in bug 53841(marked dup) was not fixed.
All contents of personal toolbar folder aren't shown on personal toolbar.

My build is 2000101220/Win32.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

18 years ago
Reopen 53841 then (it shouldn't be a DUP of this bug)
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED

Comment 12

16 years ago
Problem still exists in Mozilla 1.2.1
After I import another bookmarks in and set one of the folder as
Personal Toolbar Folder, Javascript Console Report:

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://communicator/content/bookmarks/bookmarks.js :: fillViewMenu :: line
124"  data: no]
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.