stringBundleBindings.xml uses obsolete <argument> element

RESOLVED FIXED

Status

()

P3
normal
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: jrgmorrison, Assigned: jag-mozbugs)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][rtm-], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
stringBundleBindings.xml uses obsolete <argument> element, which breaks this
XBL. This needs to be changed to the new <parameter> syntax to make this work
again. nominating: nsbeta3,rtm as this is a simple, safe fix, to make code
work again, with minimum risk (one-line XBL change to conform to new syntax).

  8     <implementation name="XStringBundle">
  9       
 10       <method name="getString">
 11         <argument name="aStringKey"/>
 12         <body>
 13         <![CDATA[
 14           try {
 15
(Reporter)

Updated

18 years ago
Keywords: correctness, nsbeta3, regression, rtm

Comment 1

18 years ago
We don't need this for beta 3.  Why should we stop ship for this?  What problem
does it cause?
Whiteboard: [nsbeta3-]
(Assignee)

Comment 2

18 years ago
Well, it happens to stop me from using this sexy xbl in the filepicker.
Of course, I could just use the regular stringbundle stuff, but this is way
sexier (no need to include strres.js everywhere meaning less bloat). And the fix
seems to be s/argument/parameter/, for which I'll attach a patch.
(Assignee)

Comment 3

18 years ago
keywords, cc
Keywords: patch, review
(Assignee)

Comment 4

18 years ago
Created attachment 15668 [details] [diff] [review]
[patch] Replace old 'argument' with new 'parameter'

Comment 5

18 years ago
nav triage team:
we don't see how this effects the user, rtm-
Whiteboard: [nsbeta3-] → [nsbeta3-][rtm-]
Target Milestone: --- → Future
(Assignee)

Comment 6

18 years ago
Taking this.
Assignee: ben → disttsc
Target Milestone: Future → ---
(Assignee)

Comment 7

18 years ago
r=hyatt
Status: NEW → ASSIGNED
Keywords: review
(Assignee)

Comment 8

18 years ago
Checked in on the trunk. Since this bug is nsbeta3-, rtm-, I'm going to mark it
fixed.
(Assignee)

Comment 9

18 years ago
duh, really marking it now.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.