high memory usage while watching videos or simply on myspace

RESOLVED DUPLICATE of bug 501485

Status

()

RESOLVED DUPLICATE of bug 501485
9 years ago
7 years ago

People

(Reporter: dwsimmington, Unassigned)

Tracking

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6

whenever on myspace, memory usage spikes up to 90,000kb  (90 MB)
this isnt too much of a problem, but becomes an issue when multiple tabs are open
when plugins and extensions are disabled, memory usage is still 70-80 MB for one tab
you can see how performance would be affected when using multiple tabs
HAVING HIGH MEMORY AND CPU USAGE WILL CAUSE A LOSS IN FIREFOX USERS AND MARKET SHARE. GOAL SUGGESTION: AIM TO KEEP MEMORY USAGE BELOW OR AROUND 100 MB WHEN 3 JAVASCRIPT AND FLASH HEAVY SITES ARE OPEN
keep up the good work guys
almost there
:)

Reproducible: Always

Steps to Reproduce:
1.www.myspace.com
2.www.youtube.com
3.www.hulu.com

** 3 tabs, 3 sites (listed above), same window **
Actual Results:  
www.myspace.com                  91 MB
www.youtube.com                 106 MB
www.hulu.com                    122 MB

122 MB is the total memory usage when these 3 tabs are open. bringing that number down just 6 MB per tab would exponentially increase multitasking capabilities.
                                

Expected Results:  
122 MB is the total memory usage when these 3 tabs are open. bringing that number down just 6 MB per tab would exponentially increase multitasking capabilities.

other than that, great job with 3.6 rc1
very responsive and snappy
here to help
thanks alot :)

Comment 1

8 years ago
ref bug 541932.

Updated

8 years ago
Version: unspecified → 3.6 Branch

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501485
You need to log in before you can comment on or make changes to this bug.