Open Bug 538844 Opened 11 years ago Updated 8 years ago

When the Bookmarks Toolbar is moved to the Menu line, its original space is left blank

Categories

(Firefox :: Toolbars and Customization, defect)

3.6 Branch
x86_64
Windows Vista
defect
Not set
minor

Tracking

()

People

(Reporter: pgorod, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)

When the Bookmarks Toolbar is moved to the Menu line, the space where it was should just disappear; instead, it still shows as a blank toolbar.

Reproducible: Always

Steps to Reproduce:
1. Go to View, Toolbars, Customize.
2. Drag "Bookmarks Toolbar Items" to the right of the menus (next to the "Help" menu).
3. Close the "Customize Toolbar" dialog by clicking "Done".
Actual Results:  
A blank toolbar appears in the space where the "Bookmarks Toolbar" originally was, below the Navigation Toolbar. See attachment 1 [details] [diff] [review].

Expected Results:  
This blank toolbar should not appear in the layout. Things should look like attachment 2 [details] [diff] [review].

There is a workaround to get the desired results: click View, Toolbars, and untick the "Bookmarks Toolbar". Instead of making this toolbar disappear completely, as I would expect, it clears the original (now blank) space below the Navigation Toolbar, and leaves the Bookmarks Toolbar showing next to the menus!...

Maybe this behavior could be a second bug; but I'm sure that fixing one will fix the other, so no need to file another bug, I guess...

I notice a subtlety: when customizing, this toolbar shows as "Bookmarks Toolbar Items". Someone might tell me that the "Bookmarks Toolbar" is one thing, always placed below the Navigation Toolbar, and its "Items" are a different thing, which I can move to a different place. With this nomenclature, Firefox's behavior would be coherent... but I claim this is misleading and totally useless. Even if some underlying implementation issue led to this, it should be hidden from the user: dragging the toolbar should result in it being definitively moved; and unticking "view" should just hide it.
In many cases people have also other things on that toolbar; not only bookmarks.
Searchbar, toolbar icons, extension icons etc.
Whiteboard: [DUPEME?]
Version: unspecified → 3.5 Branch
Ok, I see. But something seems inconsistent here. The space on the right of the menus is not a Toolbar, it is just a space; I can put things in it, but I can't hide it once it has items.

And the name "Bookmarks Toolbar" doesn't sound very precise, given I can move the bookmarks from it to another place... I fail to come up with a suggestion for an alternative, though... I agree the most general use-case is simply users who don't customize toolbars and just go check/uncheck "View Bookmarks Toolbar" to show or hide their bookmarks. The current name works well for these people, but is really weird after the "Bookmarks Toolbar Items" are moved somewhere else...

And maybe "Bookmarks Toolbar Items" can be changed to simply "Bookmarks", to eliminate the mental reference to it being a "Toolbar", which it is not.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [DUPEME?] → [CLOSEME 2011-2-25]
Hi.

Yes, I just checked with 3.6.13 in Safe Mode and everything is exactly the same.
Whiteboard: [CLOSEME 2011-2-25]
Version: 3.5 Branch → 3.6 Branch
I get the same faulty behavior, except that I have moved the bookmarks toolbar between the address bar and the search box.

This happens both with Firefox 19 release version (buildID: 20130215130331) and the latest Nightly (buildID: 20130225031141), on Windows 7 64-bit and 32-bit machines.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reproducible on the latest Beta (BuildID: 20130220104816): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

Reproducible on the latest Aurora (BuildID: 20130225042023): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130225 Firefox/21.0

Reproducible on the latest Nightly (BuildID: 20130225031141): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130225 Firefox/22.0

Note:
1. This issue is not a regression: it reproduces both on Firefox 4 and Firefox 3.6.
You need to log in before you can comment on or make changes to this bug.