Closed Bug 539265 Opened 11 years ago Closed 6 years ago

Mousing over Popup menus don't work on site using FF 3.6, work using 3.5.7

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

References

()

Details

(Keywords: regression)

Reported from hendrix user - confirming while using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6

STR:
1. Visit the site in the URL
2. Try to mouseover any of the menus. Nothing happens
3. Error: window.event is undefined
Source File: http://www.lyon-hockey-club.com/js/script.js
Line: 281 appears in console.

This works using FF 3.5.7.
Summary: Popup menus don't work on mouseover using 3.6, work using 3.5.7 → Popup menus don't work on site when using mouseover, work using 3.5.7
Summary: Popup menus don't work on site when using mouseover, work using 3.5.7 → Mousing over Popup menus don't work on site using FF 3.6, work using 3.5.7
Also confirmed on Windows.
Regression range is http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a1ee948734d4&tochange=a45593185b3a
OS: Mac OS X → All
Hardware: x86 → All
nominating to get this on the radar in case it ends up being more widespread.
Flags: blocking1.9.2?
In the script file named '0.js', there is this line of javascript, that is basically the cause of this: if(document.getBoxObjectFor!=null){window.gecko=true;
}
So this bug started appearing when getBoxObjectFor was pulled out for html documents. That means, this is a tech evangelism bug.
Assignee: nobody → english-us
Blocks: 340571
Status: UNCONFIRMED → NEW
Component: Layout → English US
Ever confirmed: true
Flags: blocking1.9.2?
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Version: 1.9.2 Branch → unspecified
No issue. 
Site has been fixed or changed.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.