Last Comment Bug 539276 - white grid-lines during fuzzy zoom out
: white grid-lines during fuzzy zoom out
Status: RESOLVED INVALID
:
Product: Fennec Graveyard
Classification: Graveyard
Component: Panning/Zooming (show other bugs)
: Fennec 1.1
: All All
-- major (vote)
: ---
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-12 11:15 PST by Madhava Enros [:madhava]
Modified: 2010-10-15 11:38 PDT (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch to overpaint (913 bytes, patch)
2010-01-12 21:15 PST, Brad Lassey [:blassey] (use needinfo?)
no flags Details | Diff | Splinter Review
patch to double buffer (2.85 KB, patch)
2010-01-13 10:31 PST, Brad Lassey [:blassey] (use needinfo?)
no flags Details | Diff | Splinter Review

Description User image Madhava Enros [:madhava] 2010-01-12 11:15:27 PST
When zooming out with the latest as of 2010-01-12, if I have an image on the screen, I get some white grid lines during the fuzzy portion of the zoom.

Example: http://www.flickr.com/photos/madhava_work/4269688214/
another: http://www.flickr.com/photos/madhava_work/4269759016/in/photostream/
Comment 1 User image Aakash Desai [:aakashd] 2010-01-12 11:42:38 PST
Yep, here's a steps to reproduce:

1. Go to www.slashdot.org/
2. Double-tap on the title of an entry there to zoom in
3. Double-tap again on the screen

Actual Results:
White grid lines will show up after the initial zoom out and before the rest of the tiles are updated.
Comment 2 User image Brad Lassey [:blassey] (use needinfo?) 2010-01-12 21:15:23 PST
Created attachment 421389 [details] [diff] [review]
patch to overpaint

not sure how I feel about this.
Comment 3 User image Brad Lassey [:blassey] (use needinfo?) 2010-01-13 10:31:27 PST
Created attachment 421478 [details] [diff] [review]
patch to double buffer

I like this patch a lot better.  The downside is it adds another canvas.
Comment 4 User image Brad Lassey [:blassey] (use needinfo?) 2010-01-13 15:19:45 PST
a third option which doesn't require the second canvas but only fixes us for zooming in (which is the case where the lines are more obvious due to them being bigger).

http://people.mozilla.org/~blassey/patches/white-lines-half-n-half.patch
Comment 5 User image Aakash Desai [:aakashd] 2010-05-03 09:31:34 PDT
I'm not seeing this anymore and I can't find a bug about this being fixed. Mark or Matt, would you have any idea if we have one? If not, we can move this to WFM.
Comment 6 User image Brad Lassey [:blassey] (use needinfo?) 2010-07-21 12:29:36 PDT
Comment on attachment 421478 [details] [diff] [review]
patch to double buffer

we don't want this patch anymore
Comment 7 User image Brad Lassey [:blassey] (use needinfo?) 2010-07-21 12:31:27 PDT
bug 437957 changed how this works entirely, resolving as fixed
Comment 8 User image Aakash Desai [:aakashd] 2010-07-22 11:27:28 PDT
This is more an invalid bug rather than fixed because bug 437957 changed the approach entirely.

Note You need to log in before you can comment on or make changes to this bug.