If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"ASSERTION: Scrolled rect smaller than scrollport?" with table

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 421354 [details]
testcase

###!!! ASSERTION: Scrolled rect smaller than scrollport?: 'result.width >= mScrollPort.width', file layout/generic/nsGfxScrollFrame.cpp, line 3061

###!!! ASSERTION: No integers in range; 0 is supposed to be in range: 'low <= high', file layout/generic/nsGfxScrollFrame.cpp, line 1722

I suspect this is a regression from bug 526394, "Move scrolling out of the view system into layout".
(Reporter)

Updated

8 years ago
Blocks: 526394
This happens because of scrollable rowgroups. The tbody frame and scrollframe are sized to 294x0, and the scrollframe also sets the tbody frame's overflow area to the same size. Then later in nsTableRowGroupFrame::CollapseRowGroupIfNecessary, the tbody frame's size and overflow area are both set to 0x0. Then we get these asserts because the overflow area of the tbody frame is smaller than the scrollport.

I'm not too sure how to fix this. Table collapsing just isn't designed to work with scrollable rowgroups.
Created attachment 421399 [details]
testcase

This testcase shows a scrollable rowgroup failing to work with a collapsed row. No scrollbars are needed, but they're shown anyway because the row collapsing is handled after we've reflowed the scrollframe.
Assignee: nobody → roc
Didn't we decide to just rip out scrollable table rowgroups? Please?
Bernd had a patch.  I reviewed it.  Then the tree was locked down, so it never landed.  See bug 28800.

Bernd, can I just push that change modulo my review comment?
Depends on: 28800
If Bernd doesn't reply in a few days, let's take silence as consent!

Comment 6

8 years ago
No, it fails a reftest. Will probably land over the weekend.
Bernd landed bug 28800 (Thanks!!!) Jesse, I presume this bug is fixed now?
(Reporter)

Comment 8

8 years ago
Yep, WFM with the testcase in comment 0.
Assignee: roc → nobody
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.