Closed Bug 539365 Opened 10 years ago Closed 10 years ago

Lightweight themes text-shadow exists on print-preview screen

Categories

(Firefox :: Theme, defect, trivial)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Firefox 3.7a1
Tracking Status
status1.9.2 --- .2-fixed

People

(Reporter: tchung, Assigned: dao)

References

Details

(Keywords: polish, verified1.9.2)

Attachments

(1 file)

The text-shadow work from light weight theme exists in windows, when entering print-preview mode.   Disabling lightweight themes will restore to default view.

* Does not reproduce on Mac OSX builds.

Repro:
1) launch 1.9.2 nightly or Fx3.6rc1
2) install any lightweight theme
3) pick a website, and go to File > Print Preview for that front page
4) Verify the header, buttons, has text-shadowing themes around it.

Expected:
- Lightweight theming text-shadowing should not affect print preview buttons

Actual:
- text-shadowed buttons
Whiteboard: [3.6b1]
Whiteboard: [3.6b1] → [3.6rc1]
Assignee: nobody → dao
Status: NEW → ASSIGNED
Component: General → Theme
QA Contact: general → theme
Attached patch patchSplinter Review
Buttons and menulists shouldn't inherit text-shadow, as they don't inherit the text color and have a background. It's not clear to me why Tony didn't see this on OS X, I think it's needed there as well.
Attachment #421419 - Flags: review?(gavin.sharp)
Severity: normal → trivial
Keywords: polish
OS: Windows XP → All
Hardware: x86 → All
Attachment #421419 - Flags: review?(gavin.sharp) → review+
(In reply to comment #1)
> Created an attachment (id=421419) [details]
> patch
> 
> Buttons and menulists shouldn't inherit text-shadow, as they don't inherit the
> text color and have a background. It's not clear to me why Tony didn't see this
> on OS X, I think it's needed there as well.

oh, thats cause mac is opening the Preview application when doing print-preview.  Versus windows using its own.
http://hg.mozilla.org/mozilla-central/rev/e8dd94ccda9d
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
Whiteboard: [3.6rc1] → [3.6rc1][rc-ridealong]?
Attachment #421419 - Flags: approval1.9.2.1?
Whiteboard: [3.6rc1][rc-ridealong]? → [3.6rc1]
blocking1.9.2: --- → ?
Duplicate of this bug: 545411
blocking1.9.2: ? → ---
Comment on attachment 421419 [details] [diff] [review]
patch

a1922=beltzner
Attachment #421419 - Flags: approval1.9.2.2? → approval1.9.2.2+
Keywords: checkin-needed
Whiteboard: [3.6rc1]
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3pre) Gecko/20100322 Namoroka/3.6.3pre
Keywords: verified1.9.2
You need to log in before you can comment on or make changes to this bug.