Fennec Does not attempt to re-establish Connection

VERIFIED DUPLICATE of bug 530075

Status

Fennec Graveyard
General
--
major
VERIFIED DUPLICATE of bug 530075
8 years ago
8 years ago

People

(Reporter: LonelyBob, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Gecko/20100112 Namoroka/3.6pre Fennec/1.1a1pre

Fennec initiates a connection when a new URL is entered in the addrss bar, but does Not re-initiate the connection when Connection is disconnected or lost and Fennec is already open and running. 
For example, Visit a webpage, Disconnect the connection, then return to Fennec and click on a link in the Browser. The Firefox Offline page is shown, eventhough network is available. 
Browser should automatically try to connect, and only if network is Not available show the Offline page.

Reproducible: Always

Steps to Reproduce:
1. Open Fennec and visit a webpage (ie. twitter.com )
2. Switch to Network Connection manager, and Disconnect the network connection.
3. Switch back to Fennec, and click on a link on the page. (ie. About us link on twitter.com )

Actual Results:  
Offline mode page is shown, "Firefox is currently in offline mode and can't browse the web" with a button to Try again.

Expected Results:  
Network is re-established automatically, webpage is downloaded and displayed.
Only when there is No network connection available should the Offline page be displayed.

Repeat these same steps with the default N900 Maemo Browser, and the connection is automatically re-established. This is more convenient for the user.
1. Open Maemo Browser and visit a webpage, such as twitter.com 
2. Switch to Network Connection manager, and Disconnect the network connection.
3. Switch back to Maemo Browser, and click on a link on the page. (ie. About us link on twitter.com )
Actual Result: Connection is automatically re-established, webpage is displayed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 530075
dupe, v. I'm going to move the steps to reproduce over to the other bug as it's a very usable bug report.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
Hardware: Other → ARM
You need to log in before you can comment on or make changes to this bug.