Closed Bug 539706 Opened 10 years ago Closed 10 years ago

Provide an async AddVisit

Categories

(Toolkit :: Places, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 556400

People

(Reporter: mak, Unassigned)

References

Details

Purposes:
- reduce IO on main thread
- remove lazy_add (visit messages accumulate and slow down things)
- solve concurrent async expiration and sync addVisit (addVisit can add a uri, and expiration can run immediately after, this is actually workarounded looking at table ids)
I'll likely grab this after bug 461199 since I'm pretty sure e10s needs this as well too!
Depends on: 542941
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 556400
You need to log in before you can comment on or make changes to this bug.