Closed Bug 539876 Opened 12 years ago Closed 12 years ago

nanojit: optimize away 'y = mul x, 1'

Categories

(Core Graveyard :: Nanojit, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: n.nethercote, Assigned: n.nethercote)

References

Details

(Whiteboard: fixed-in-nanojit, fixed-in-tracemonkey)

Attachments

(1 file)

Attached patch patchSplinter Review
ExprFilter is pretty aggressive, but it misses this one.  It shows up in TM code sometimes because we index into a table like this:

  n * sizeof(JSTraceType)

and sizeof(JSTraceType) == 1.
Attachment #421776 - Flags: review?(rreitmai)
Attachment #421776 - Flags: review?(rreitmai) → review+
http://hg.mozilla.org/tracemonkey/rev/b831915b57af
Whiteboard: fixed-in-nanojit → fixed-in-nanojit, fixed-in-tracemonkey
Duplicate of this bug: 532727
http://hg.mozilla.org/mozilla-central/rev/b831915b57af
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.