More than one Wordpress installation: FF cannot remember all passwords

RESOLVED DUPLICATE of bug 263387

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 263387
8 years ago
6 years ago

People

(Reporter: Yasir Wazir, Unassigned)

Tracking

5 Branch
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 GTB6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 GTB6

I have multiple wordpress installations in my site. Main site is wordpress, then there is a news section and blog that also use WP.

For such a long time, I thought FF will solve this issue but it is still there in the latest FF.

The problem is that: for all WP installed within my one site, username is the same. Now, FF cannot seem to remember the password for all WP based sections in my site.

Like, homepage is: http://www.a1newspapers.com/

Lets say FF have saved the username and Pass for admin panel for this site.

But then for this section:

http://www.a1newspapers.com/blog/

When I enter login info, FF does ask to save the info: if I select Yes, then the password for this section will over write the password that FF saved for the main site.

hence, only one password is saved for multiple sections of WP.

Can you solve this issue? Or I am doing something wrong? 

Reproducible: Always
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

7 years ago
I am currently using Firefox 3.6.12 and I am still having this issue:

FF does not remember all the passwords if you have multiple installations of Wordpress in one website.

I will now check in Firefox 3.6.13
(Reporter)

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Updated

7 years ago
Whiteboard: [CLOSEME 2011-1-30]
Version: unspecified → 3.6 Branch

Updated

6 years ago
Component: General → Password Manager
Product: Firefox → Toolkit
QA Contact: general → password.manager
Version: 3.6 Branch → 1.9.2 Branch

Comment 4

6 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 5? Does the issue occur with the latest nightly? http://nightly.mozilla.org/
(Reporter)

Comment 5

6 years ago
I am using FF5 and am still facing this issue:

I have multiple Wordpress installations in one domain: now FF does only remember password for One installation. All installations uses the same username that is ADMIN.

Comment 6

6 years ago
Are they on sub-domains or just different paths? i.e. blog.site.com and blog2.site.com or site.com/blog1 and site.com/blog2
Version: 1.9.2 Branch → 5 Branch
(Reporter)

Comment 7

6 years ago
All Wordpress installations are in one Main Domain: No subdomains.

Main domain is using Wordpress here:

http://www.a1newspapers.com/

Now another Wordpress installation is here:

http://www.a1newspapers.com/blog/

Just like this, there are other installations too.

Comment 8

6 years ago
In researching this I found you can store multiple accounts on the same domain as long as they use a different username. Only 1 combination of site/username is allowed. If you put the blogs on sub-domains the issue would go away.

So...2 choices currently: use different username or move to sub-domains.

Duping to bug 263387 - which is a WONTFIX

Bug 436275 is also similar (and has a patch) - but also was a WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263387
You need to log in before you can comment on or make changes to this bug.