Open Bug 540164 Opened 12 years ago Updated 3 years ago

Improve console outputs

Categories

(Developer Services :: Mercurial: qimportbz, defect)

defect
Not set
minor

Tracking

(Not tracked)

ASSIGNED

People

(Reporter: sgautherie, Assigned: sgautherie)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1304] )

Attachments

(1 file)

No description provided.
Attached patch (Av1) Just do itSplinter Review
*s/print "Warning: /bug.settings.ui.warn/ to sync with the rest of the code.
*Bug fetching: remind bug number, be more readable in case of errors.
Attachment #422001 - Flags: review?(tellrob)
Comment on attachment 422001 [details] [diff] [review]
(Av1) Just do it

I like the print change and displaying the bug number when fetching.

I don't like the new style of splitting the "Doing x" "done" messages onto separate lines. It makes it unnecessarily more verbose. You could just eliminate the "done" messages if that's more appealing but do we really need to change it?
(In reply to comment #2)

Do we actually care for 1-2 more lines?
Getting the errors on the "Parsing..." line is more a concern, I think.
If you do want 1 line only, I could only do the opposite: remove the "..." line and merge it with the "Done" line :-|

Example of the issue from bug 533890:
"Parsing...** unknown exception encountered, details follow"
(In reply to comment #3)
> (In reply to comment #2)
> 
> Do we actually care for 1-2 more lines?
I think it looks much nicer.

> Getting the errors on the "Parsing..." line is more a concern, I think.
> If you do want 1 line only, I could only do the opposite: remove the "..." line
> and merge it with the "Done" line :-|
> 
> Example of the issue from bug 533890:
> "Parsing...** unknown exception encountered, details follow"

I do like this. A nicer looking message would be something like "Parsing...failed. Details follow:". I think the asterisks are rather unsightly.
Attachment #422001 - Flags: review?(tellrob)
Product: Other Applications → Developer Services
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/291]
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/291] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1293] [kanban:engops:https://kanbanize.com/ctrl_board/6/291]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1293] [kanban:engops:https://kanbanize.com/ctrl_board/6/291] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1298] [kanban:engops:https://kanbanize.com/ctrl_board/6/291]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1298] [kanban:engops:https://kanbanize.com/ctrl_board/6/291] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1299] [kanban:engops:https://kanbanize.com/ctrl_board/6/291]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1299] [kanban:engops:https://kanbanize.com/ctrl_board/6/291] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1304] [kanban:engops:https://kanbanize.com/ctrl_board/6/291]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1304] [kanban:engops:https://kanbanize.com/ctrl_board/6/291] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1304]
Greg, is qimportbz still a thing? :)
Thanks!
Flags: needinfo?(gps)
qimportbz is still a thing. The code has been on life support for years. I'm surprised it has continued to apparently work with so little testing and supervision.
Flags: needinfo?(gps)
You need to log in before you can comment on or make changes to this bug.