Cannot compose msg if account has > 1 identity

VERIFIED DUPLICATE of bug 48757

Status

MailNews Core
Composition
P3
normal
VERIFIED DUPLICATE of bug 48757
18 years ago
10 years ago

People

(Reporter: BenB, Assigned: Jean-Francois Ducarroz)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Reproduce:
1. Add several identities to your an account by editing prefs.js.
2. |New Msg|

Actual result:
- Errors on the console (attached below)
- No "From" list
- Body not editable

Additional Comments:
This is a recent (last week) regression.

Console output:
ComposeMessage folder=[xpconnect wrapped nsIMsgFolder]

ComposeMessage from XUL: [nsIMsgIdentity: id1,id2,id3,id4,id5,id6]

ComposeLoad from XUL
Compose: ComposeStartup
[preselectid=id1]
[format=0]
[type=0]
[nsIMsgIdentity: id1,id2,id3,id4,id5,id6]
JavaScript error: 
chrome://messenger/content/messengercompose/MsgComposeCommands.js line 1537:
item has no properties

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[JavaScript Error: "msgCompose has no properties" {file:
"chrome://messenger/content/messengercompose/MsgComposeCommands.js" line: 230}]
[nsIController::isCommandEnabled]"  nsresult: "0x80570021
(NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame ::
chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 57"  data:
yes]
************************************************************
An error occurred updating the cmd_showFormatToolbar command
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[JavaScript Error: "msgCompose has no properties" {file:
"chrome://messenger/content/messengercompose/MsgComposeCommands.js" line: 230}]
[nsIController::isCommandEnabled]"  nsresult: "0x80570021
(NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame ::
chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 57"  data:
yes]
************************************************************
An error occurred updating the cmd_showFormatToolbar command
(Reporter)

Updated

18 years ago
Keywords: regression
(Assignee)

Comment 1

18 years ago
Ben, can you give me a sample of what you add manually into your prefs that 
cause the problem. thanks
(Reporter)

Comment 2

18 years ago
Copy/paste prefs mail.identity.id1.* and rename to *.id2.*, *.id3.* etc.
(assuming you had only one identity). Then set
user_pref("mail.account.account1.identities", "id1,id2,id3,id4,id5,id6");|
(Reporter)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
> This is a recent (last week) regression.

Am I sure? There's already an old bug about this (but other symptoms). ???

*** This bug has been marked as a duplicate of 48757 ***

Comment 4

18 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.