Last Comment Bug 540450 - reordering markers while editing custom google maps broken
: reordering markers while editing custom google maps broken
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Event Handling (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://maps.google.com/
: 542923 643728 646800 (view as bug list)
Depends on: 540491
Blocks: 503943
  Show dependency treegraph
 
Reported: 2010-01-18 10:04 PST by David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
Modified: 2011-04-13 07:31 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2010-01-18 10:04:19 PST
I originally described this in bug 517737 comment 20:
> Another set of Google Maps steps that regressed on the same day, but don't seem
> to be fixed by the pair of patches above:
>  (1) while logged in to google, create a map using the "My Maps" - "Create a
> Map" feature in http://maps.google.com/
>  (2) create at least 2 placemarks in that map
>  (3) while editing, drag the placemarks up and down to reorder them
> 
> The dragging of placemarks while editing a map broke in the same regression
> range, but isn't fixed by attachment 420271 [details] [diff] [review] plus attachment 420273 [details] [diff] [review].
Comment 1 Timothy Nikkel (:tnikkel) 2010-01-18 15:02:04 PST
While following the above STR I came across bug 540491. So you may need to create the custom map in another build before hand to see this bug.
Comment 2 Timothy Nikkel (:tnikkel) 2010-01-18 15:04:41 PST
The problem is that google maps is calling setCapture on a display: none element. I checked in IE and calling setCapture on a display: none element does work there.
Comment 3 Neil Deakin (away until Oct 3) 2010-01-19 11:11:08 PST
(In reply to comment #2)
> The problem is that google maps is calling setCapture on a display: none
> element. I checked in IE and calling setCapture on a display: none element does
> work there.

I don't think real mouse events can target elements without frames. Similar to bug 540491, we only capturing to work while the mouse is pressed to prevent abuse, so if setCapture is being called outside of a mousedown, it won't have any effect.
Comment 4 Timothy Nikkel (:tnikkel) 2010-01-19 13:46:16 PST
I think setCapture is being called from a mousedown, just that the element that the mousedown is on is different from the one that gets setCapture called on it.
Comment 5 Neil Deakin (away until Oct 3) 2010-02-01 18:04:58 PST
*** Bug 542923 has been marked as a duplicate of this bug. ***
Comment 6 Oskar Ivanić (:icecold) 2010-11-25 18:55:16 PST
Is this same bug?
When you are creating "My Map" on Google Maps and when you select "Add a placemark" the icon stays there even if you're moving mouse?
Here is a screenshot: http://img836.imageshack.us/f/googlemapse.jpg/
Comment 7 Timothy Nikkel (:tnikkel) 2010-11-25 20:26:27 PST
I think that is bug 540491.
Comment 8 Alice0775 White 2011-03-22 07:24:53 PDT
*** Bug 643728 has been marked as a duplicate of this bug. ***
Comment 9 Alice0775 White 2011-03-31 17:51:59 PDT
*** Bug 646800 has been marked as a duplicate of this bug. ***
Comment 10 Chip Chapin 2011-04-02 14:34:16 PDT
Hi, I'm making the fix in Google Maps for bug 540491. Checking all the setCapture uses fixes this bug too, I'm hoping the fix will be live within a week.
Comment 11 Dr B W Darvell 2011-04-03 22:53:57 PDT
FF 4.0, XP pro sp3, fully patched.
I have been using a custom map with FF 3.x for a long time, no problem.  Now, if I try to edit and add a marker, the marker is placed under the icon.  If I scroll the map to show it, then try to grab it with the mouse to place it correctly, it leaps out of the way - just like a spoof game or an annoying virus (except as far as I know the machine is clean).  It works properly under IE8 (garlic!).  The uncontrolled scrolling also occurs: this requires the mouse to reach the top edge of the map, and then there is no way to stop it.  The only way then is to close the tab, no other escape.  If I do not try to reach the marker, but grab the map with L-mouse-down, the cursor disappears right of the left-most edge of the edit icons (and then stays invisible), the marker still jumps, but now I get a pop-up box "Click to place me on the map", which will not go away.  In fact, if I now say "Done", the cursor stays invisible, the marker still jumps if I get close to it (by trial and error).
Hoping the fix is forthcoming.  I shall not be updating my other machines until.
Comment 12 Chip Chapin 2011-04-04 09:45:30 PDT
(In reply to comment #11)
@Dr Darvell, that is bug 540491.  The fix should be live in Google Maps by the end of the week if all goes well.
Comment 13 Dr B W Darvell 2011-04-04 09:54:19 PDT
OK, thanks - look forward to it.
Comment 14 Neil Deakin (away until Oct 3) 2011-04-12 18:24:12 PDT
Chip, is this one fixed as well?
Comment 15 Dr B W Darvell 2011-04-13 01:10:51 PDT
Seems to be OK for me.
Thanks all.
Comment 16 Chip Chapin 2011-04-13 07:29:01 PDT
Yes Neil. And thanks for all your analysis on these, which was spot on. I should have given you kudos in my comments on the other bug.
Comment 17 Neil Deakin (away until Oct 3) 2011-04-13 07:31:55 PDT
OK thanks for the fix!

Note You need to log in before you can comment on or make changes to this bug.