Last Comment Bug 540460 - [@ resampler_basic_interpolate_single] Flash crashes when i type search string with youtube video playing on background
: [@ resampler_basic_interpolate_single] Flash crashes when i type search strin...
Status: RESOLVED INVALID
: crash
Product: External Software Affecting Firefox
Classification: Components
Component: Flash (Adobe) (show other bugs)
: unspecified
: x86 Linux
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-18 10:55 PST by fynjy-007
Modified: 2016-04-28 10:07 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Firefox test #1 (3.23 KB, text/plain)
2010-01-18 14:40 PST, fynjy-007
no flags Details
Firefox test #2 (175 bytes, text/plain)
2010-01-18 14:42 PST, fynjy-007
no flags Details
Firefox test #3 (181 bytes, text/plain)
2010-01-18 14:43 PST, fynjy-007
no flags Details
Firefox test #3 (175 bytes, text/plain)
2010-01-18 14:43 PST, fynjy-007
no flags Details

Description fynjy-007 2010-01-18 10:55:42 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.1.7) Gecko/20091222 SUSE/3.5.7-2.4 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.1.7) Gecko/20091222 SUSE/3.5.7-2.4 Firefox/3.5.7

Firefox may be crash on several sites when i use search tool on the site page. In another tab must be playing video from youtube.

Reproducible: Always

Steps to Reproduce:
1. go on www.youtube.com and launch any video
2. open new tab and go http://www.citforum.ru/security/cryptography/openssl/
3. press ctrl+f and type
asn

Actual Results:  
browser will terminated with segmentation fault

Expected Results:  
browser must say: «search string not found»

openSuSE linux 11.2 x86;
kde 4.3.4 release 2;
flash-player-10.0.42.34-0.1.1.i586;
firefox 3.5.7-2.4 installed from http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/
Comment 2 fynjy-007 2010-01-18 14:40:54 PST
Created attachment 422264 [details]
Firefox test #1

search on http://en.opensuse.org/Bugs:mozilla for text «asn» with random video in another tab
Comment 3 fynjy-007 2010-01-18 14:42:37 PST
Created attachment 422265 [details]
Firefox test #2

search on http://en.opensuse.org/Bugs:mozilla for text «asn» with some random video on another tab
Comment 4 fynjy-007 2010-01-18 14:43:05 PST
Created attachment 422266 [details]
Firefox test #3

search on http://en.opensuse.org/Bugs:mozilla for text «asn» with some random video on another tab
Comment 5 fynjy-007 2010-01-18 14:43:32 PST
Created attachment 422267 [details]
Firefox test #3

search on http://en.opensuse.org/Bugs:mozilla for text «asn» with some random video on another tab
Comment 6 fynjy-007 2010-01-18 14:45:49 PST
Maybe the problem is caused by a sound signal, which should play, if nothing is found.
Comment 7 timeless 2010-01-18 15:31:53 PST
so, resampler_basic_interpolate_single is pulseaudio, you should file a bug with them. i've cc'd someone from Flash since they called pulse, but i suspect it's just a bug in pulse.
Comment 8 fynjy-007 2010-01-19 01:49:00 PST
Strange, pulse is not active on my computer. Can application detect if pulse audio is active and route sound to appropriate device (pulse or alsa)? Or with this problem should deal pulseaudio libs?
Comment 9 timeless 2010-01-19 01:57:30 PST
sorry. lemme restate:

*File* a bug with your vendor (SUSE) indicating that pulse is crashing and include this bug's url.

This Bugzilla manages bugs in Mozilla Firefox. We do not manage bugs in SUSE, PulseAudio, or Flash. To the extent that we have contributors from these organizations, they can help triage bugs (and take them to their own trackers), however, this bug has been triaged, it does not belong in our bug tracker.

We are not experts in anything other than Firefox and can not offer support on any such things. Whereas, SUSE and Adobe can help w/ their respective pieces.
Comment 10 fynjy-007 2010-01-19 02:16:44 PST
Ок, thanks.
Comment 11 fynjy-007 2010-01-19 02:39:24 PST
Created ticket for pulse audio http://pulseaudio.org/ticket/780
Comment 12 timeless 2010-01-19 03:30:26 PST
thanks!
Comment 13 Colin Guthrie 2010-01-19 04:05:00 PST
As far as I can tell, comment 7 is wrong. The symbols in question are in fact from the pph plugin from alsa-plugins. I see no mention of any PA symbols in the backtrace.
Comment 14 timeless 2010-01-19 04:54:01 PST
colin: thanks, sorry, google mislead me, in my defense, in comment 9, i specifically mentioned SUSE/Adobe and not pulse as the places for filing bug reports.

The point is that the people who work here are not experts, at best we can say "sorry, you need to contact someone else".
Comment 15 Colin Guthrie 2010-01-19 05:26:54 PST
Indeed :) Rereading my previous comment, it was a bit terse... I didn't mean to sound narky! KUTGW :)
Comment 16 fynjy-007 2010-01-19 06:10:53 PST
Filed report for alsa https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4878
If here no results i go to suse or adobe :)
Comment 17 Colin Guthrie 2010-01-19 07:21:24 PST
Just for reference the ALSA bug tracker is a bit of a black hole... Generally speaking most folks discuss problems on the ALSA mailing list which generally proves much more effective. I've brought up the issue of the bugtracker before with alsa folks but not a lot happened... anyway that is off topic for here :)
Comment 18 Colin Guthrie 2010-01-19 09:52:32 PST
After a small prompt from someone who will remain timeless... I mean nameless.. I highlighted this issue on the alsa-devel mailing list for you:

http://thread.gmane.org/gmane.linux.alsa.devel/69942

I also asked a more general question about the state of the bugtracker to see how it's fairing these days and will follow up on that depending on replies to see if it can be either tidied up, replaced, or shut down for new submissions in order to get a good workflow moving forward.

Take care
Comment 19 fynjy-007 2010-01-19 10:36:41 PST
Thank you. Hopefully tracker there really works. I just wanted to wait some time before writing to the mailing list. Reporting bugs is really a new experience for me.
Comment 20 Charles 2010-01-20 13:47:02 PST
Also if you are sure its not a firefox bug and issue with Flash Player  I would suggest letting Adobe know via www.bugs.adobe.com/flashplayer
Comment 21 BMO Automation 2016-04-28 10:07:52 PDT
Version and milestone values are being reset to defaults as part of product refactoring.

Note You need to log in before you can comment on or make changes to this bug.