Customizable right click menu

RESOLVED DUPLICATE of bug 164955

Status

()

Firefox
Menus
--
enhancement
RESOLVED DUPLICATE of bug 164955
8 years ago
8 years ago

People

(Reporter: Gregory Stec, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; pl; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; pl; rv:1.9.2) Gecko/20100115 Firefox/3.6

The most interesting future to enhance navigation ergonomy is to provide to customers ability to customize "right click menu". This should include menu grouping and add entry to enter to any menu bar menu or any position in any main menu bar menu or to any bar menu menu position function like "enhanced settings" in menu Tools/Settings finally. This enhancement speedy work with page minimize cursor movement in the case of need to close tab, open bookmarks or manage addons, access universal url/search entry field. As the final stage of this concept customized "right click menu" will give the customer ability to replace and turn on/off with maybe hot-key, the standard menu bar and enlarge (maximize)the browser view window. This will enter the full screen adventage to scalable browser window with enhanced (fully customizable) "right click menu". The turn on/off standard menu bar could be made with F11 or SHIFT+F11 or customizable HOT-KEY. 

Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 164955
You need to log in before you can comment on or make changes to this bug.