Results confined of last searched bugs while editing search after clicking on "showing last searched results"

RESOLVED DUPLICATE of bug 325123

Status

()

Bugzilla
Query/Bug List
--
minor
RESOLVED DUPLICATE of bug 325123
8 years ago
8 years ago

People

(Reporter: keerthi, Unassigned)

Tracking

3.2.2
x86
Windows XP

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.17) Gecko/2009122116 Firefox/3.0.17 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.17) Gecko/2009122116 Firefox/3.0.17 (.NET CLR 3.5.30729)

Editng a last searched bug list automatically includes the bugz in the last searched list by populating the "Only Include" Bugz numberd "<list of bugs from last searched result set>". 
The workaround is simply deleting all the bug numbers in this field to get an accurate result. But this is unexpected behavior as the search criteria is altered without the users knowledge.

Reproducible: Always

Steps to Reproduce:
1. Login to Bugzilla and click on a saved search.
2. Open the any bug in the list.
3. Click on "Show last search results" to get back the search.
4. Click on "Edit Search"
The resulting advanced search screen contains all the bug numbers from the last search in the "Only Include" Bugz numberd "<list of bugs from last searched result set>" field
Actual Results:  
The result set after editing is confined to the last set of results if the user does not notice this anomaly.

Expected Results:  
The advanced search page should not populate with the last search result set.

Bugzilla Version: 3.2.2
Browser Version: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.17) Gecko/2009122116 Firefox/3.0.17 (.NET CLR 3.5.30729)

OS version: Windows XP sp2

Updated

8 years ago
Assignee: nobody → general
Component: General → Bugzilla-General
Product: Core → Bugzilla
QA Contact: general → default-qa

Updated

8 years ago
Assignee: general → query-and-buglist
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Bugzilla-General → Query/Bug List
Resolution: --- → DUPLICATE
Version: unspecified → 3.2.2
Duplicate of bug: 325123
You need to log in before you can comment on or make changes to this bug.