The default bug view has changed. See this FAQ.

[Mac classic] On received messages, if too many attachments, scroll bar works but is not visible

VERIFIED FIXED in seamonkey2.1a1

Status

SeaMonkey
Themes
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Luke Odom, Assigned: stefanh)

Tracking

({fixed-seamonkey2.0.5})

Trunk
seamonkey2.1a1
All
Mac OS X
fixed-seamonkey2.0.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

222.91 KB, image/tiff
Details
16.24 KB, image/png
Details
592 bytes, patch
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.7) Gecko/20100105 Lightning/1.0b1 SeaMonkey/2.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.7) Gecko/20100105 Lightning/1.0b1 SeaMonkey/2.0.2

On received messages, if too many attachments, scroll bar works but is not visible 

Reproducible: Always

Steps to Reproduce:
1. Receive message with multiple attachments.
2. Open message either in message pane or own windows.
3. Click scroll bars to scroll through attachments.
Actual Results:  
Scrolling works if you click where the scroll bar should be but the scroll bar is not visible at all.

Expected Results:  
Click on visible scroll bar to scroll through attachments.

Using default theme.
(Reporter)

Comment 1

7 years ago
Created attachment 422652 [details]
Screenshot

If you click on the bottom of the silver bar to the right of the attachments it scrolls.
(Reporter)

Updated

7 years ago
Version: unspecified → SeaMonkey 2.0 Branch
(Reporter)

Comment 2

7 years ago
I switched to SeaMonkey modern theme and the scroll bars appear as expected.
(Reporter)

Updated

7 years ago
Component: MailNews: General → Themes
(Assignee)

Comment 3

7 years ago
I see this in 2.0.2 (and it probably happens on trunk too). I guess the native mac scrollbar could have some kind of minimum height, because it works when I add the attachments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PowerPC → All
Version: SeaMonkey 2.0 Branch → Trunk
(Assignee)

Updated

7 years ago
Summary: On received messages, if too many attachments, scroll bar works but is not visible → [Mac classic] On received messages, if too many attachments, scroll bar works but is not visible
nsNativeThemeCocoa.mm has #define MIN_SCROLLBAR_SIZE 56
and the list in the screenshot is 54px high. So maybe the easiest fix is just to set min-height: 56px on it.
(Assignee)

Comment 5

7 years ago
Created attachment 428277 [details] [diff] [review]
Make scrollbar visible

Thanks Markus, yeah that would be the easiest fix ;-)

I did had to set a min-height of 58px and then a min-height on the header itself - otherwise you'll get a scrollbar for the header. Hmm, those headers needs love. I guess this is OK for a branch fix, but on trunk we should do an overhaul of those rules.
Assignee: nobody → stefanh
Status: NEW → ASSIGNED
Attachment #428277 - Flags: review?(mnyromyr)

Comment 6

7 years ago
Comment on attachment 428277 [details] [diff] [review]
Make scrollbar visible

Looks sensible.
Attachment #428277 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 7

7 years ago
Comment on attachment 428277 [details] [diff] [review]
Make scrollbar visible

Neil, I guess you might want to look at this.
Attachment #428277 - Flags: superreview?(neil)

Comment 8

7 years ago
(In reply to comment #5)
> I did had to set a min-height of 58px and then a min-height on the header
> itself - otherwise you'll get a scrollbar for the header.
Can you explain this please (screenshot perhaps?)
(Assignee)

Comment 9

7 years ago
Created attachment 435661 [details]
screenshot

First row is without the patch, third image is with the patch, but without the min-height on the header. I now realize that I could probably set a min-height on the expandedAttachmentList instead (82px, 1px more than the calc. height).
Comment on attachment 428277 [details] [diff] [review]
Make scrollbar visible

>+#expandedHeaderView {
>+  min-height: 84px;
This can't be right, since it overrides the height even when there are no attachments. At the very least you should put the min-height on the expandedAttachmentBox, but at least in Modern I can't get any random heights (below 14em, of course) to cause the expandedHeaderView to scroll, so there's still something wacky going on somewhere...
Attachment #428277 - Flags: superreview?(neil) → superreview-
(Assignee)

Comment 11

7 years ago
Created attachment 435702 [details] [diff] [review]
new version

Turns out that the native listbox causes the scrollbar - setting -moz-appearance: none, makes the extra scrollbar go away. The listbox looks quite bad, though. Anyway, here's a new version that set 0 top/bottom margin on the listbox - that works too.
Attachment #435702 - Flags: superreview?(neil)

Updated

7 years ago
Attachment #435702 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 12

7 years ago
Comment on attachment 435702 [details] [diff] [review]
new version

I think we should take this on branch - it's a safe theme tweak that improves usability.
Attachment #435702 - Flags: approval-seamonkey2.0.5?

Updated

7 years ago
Attachment #435702 - Flags: approval-seamonkey2.0.5? → approval-seamonkey2.0.5+
(Assignee)

Updated

7 years ago
Attachment #428277 - Attachment is obsolete: true
(Assignee)

Comment 13

7 years ago
http://hg.mozilla.org/comm-central/rev/87d7ac659d9a
http://hg.mozilla.org/releases/comm-1.9.1/rev/daeafd052434
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: fixed-seamonkey2.0.5
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a1
(Reporter)

Comment 14

7 years ago
I just checked with 2.0.5 and it works. Scrollbar rendered as expected. Thanks for all the hard work guys!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.