Last Comment Bug 540984 - Foxyproxy not aligned correctly in the Tools menu
: Foxyproxy not aligned correctly in the Tools menu
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-20 17:01 PST by Drew Ruderman
Modified: 2011-12-28 11:43 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of Foxyproxy in Tools Menu (16.74 KB, image/png)
2010-01-20 17:01 PST, Drew Ruderman
no flags Details
screenshot on ubuntu (40.56 KB, image/jpeg)
2010-01-21 11:32 PST, Eric H. Jung
no flags Details

Description Drew Ruderman 2010-01-20 17:01:21 PST
Created attachment 422658 [details]
Screenshot of Foxyproxy in Tools Menu

3.6 RC2: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

Trunk: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20100116 Minefield/3.7a1pre (.NET CLR 3.5.30729)

Foxyproxy's menu item within the Tools menu is aligned incorrectly.

Steps to Reproduce:
1. Navigate to Tools | Addons | Get Add-ons
2. Search for foxyproxy.
3. Select and click "Add to Firefox."
4. Install.
5. Restart Firefox.
6. Navigate to the Tool menu item.
Comment 1 Eric H. Jung 2010-01-21 11:31:55 PST
Yeah, I know. There's also a missing arrow next to the Tools->FoxyProxy Standard menu item. I'm open to patches or at least guidance on how to fix it. The relevant code is here:
http://fisheye2.atlassian.com/browse/foxyproxy/trunk/src/content/overlay.js?r=578#l618
This dynamically builds the menu not just for Tools, but also for the context-menu (right-click), and the menu that's displayed when FoxyProxy is clicked in the statusbar.
Attached screenshot of Tools menu in Ubuntu. You can see the missing arrow but alignment is proper AFAICT.
Comment 2 Eric H. Jung 2010-01-21 11:32:25 PST
Created attachment 422807 [details]
screenshot on ubuntu
Comment 3 Eric H. Jung 2010-01-22 16:54:37 PST
I suspect I'm not using the right CSS classes on the menu and menuitem elements. I don't know.

Note You need to log in before you can comment on or make changes to this bug.