Closed Bug 541212 Opened 11 years ago Closed 11 years ago

Allow setters to be called on sealed objects

Categories

(Core :: JavaScript Engine, defect)

Other Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 492849
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: jorendorff, Assigned: jimb)

References

(Depends on 1 open bug)

Details

We want to align JS_SealObject with ES5 Object.freeze. This is a first step needed by js-ctypes.
Blocks: es5
No longer blocks: 513788
See bug 492845, ES5: Implement Object.seal().
This should fall out of ES5 extensibility work.
Assignee: jorendorff → jwalden+bmo
Depends on: 492849
No longer depends on: 492849
blocking2.0: --- → beta5+
Just needs to hit feature freeze, can be b6.
blocking2.0: beta5+ → beta6+
Assignee: jwalden+bmo → jim
The patch for bug 492849 seems to make this work: setters on (say) JSPROP_SHARED|JSPROP_PERMANENT attributes found on the prototype get called even when the inheriting object is NOT_EXTENSIBLE.

This does cause some new failures, as outlined in bug 598225.
Depends on: 598225
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492849
You need to log in before you can comment on or make changes to this bug.