Firefox 3.6 Personas doesn't work when you mouseover the image.

RESOLVED WORKSFORME

Status

()

Firefox
Theme
--
major
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: loganfynne12596, Unassigned)

Tracking

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120615], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I just installed Firefox 3.6, and then I went to the Personas, and I can't see the preview when I mouse over the image.

Reproducible: Always

Actual Results:  
It doesn't show the Persona preview anymore.
Can you start in safe mode and test? http://support.mozilla.com/en-US/kb/Safe+Mode
WFM with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100120 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20100120043108
Version: unspecified → 3.6 Branch

Comment 2

9 years ago
Hey, 

I have the same error.
For more information see here:
https://bugzilla.mozilla.org/show_bug.cgi?id=541539
Previewing doesn't work for third-party themes. If you're using a third-party theme, this is essentially a duplicate of bug 520124.

Comment 4

9 years ago
Directly after installing FF3.6 some values are set as xpinstall.whitelist.add...
These are responsible for hovering over themes to show a preview of these themes. 

Is there a reason, why this feature becomes -without any notice to the user- deactivated after the first restart of FF?

Comment 5

9 years ago
Or with other words:

It is wrong, that previewing third-party themes did not work.

For me directly after installing the browser, previewing themes works. 
After I restart the browser (without changing any settings) previewing themes stops working.

I also tested this on another PC now: Previewing themes works there. Also for third party themes and also after restarting the browser.

I do not see, why it should -in your eyes- be no bug, if this feature stops working.
Please look for a fix.
I'm not saying that there's no bug, though it's possible that there's none. Anyway, I'm saying that xpinstall.whitelist.add being empty is expected and would not be part of that bug.

Logan: Please report back as to whether or not you're using the default theme.

Comment 7

9 years ago
Since I have the same symptoms:

After having restarted the browser, the preview does no longer work. This problem is there with the default theme and with the others I have tested until now, so the theme used does not seem to matter.
Comment 0 doesn't say anything about a restart.

Comment 9

9 years ago
He writes, that it "does not work _anymore_". So it worked before, exactly as it did for me. Only Logan will be able to tell you, if there was a restart.

However, Dão, if xpinstall.whitelist.add... is expected to be empty, why is it then set to another value by default?
And why does setting this default again fix the issue?
These facts given I just don't understand why emptying this value should not be the cause for this bug.
(In reply to comment #9)
> However, Dão, if xpinstall.whitelist.add... is expected to be empty, why is it
> then set to another value by default?

Read the code and try to figure it out yourself? This really isn't the place to discuss this.

> And why does setting this default again fix the issue?

It's possible that the permissions for getpersonas.com weren't stored correctly. permissions.sqlite is expected to contain them.
(Reporter)

Comment 11

9 years ago
It did work for me at first.

Comment 12

9 years ago
I used the feature "delete history" (e.g. when cosing the browser).
I now changed the prefs and unchecked "Clear site preferences" there.
This does not fix the issue, but it's a workaround.

Logan, does this fix the issue for you, too?

If so, this is a duplicate of
https://bugzilla.mozilla.org/show_bug.cgi?id=506446

Comment 13

9 years ago
I have the same, if not a similar problem.

Mouse over doesn't work for previewing personas and if I try to change my persona it asks me to allow it and then it's added as a theme in my themes.

Mouse over works on the little persona icon on the bottom left, when you pull up the menus of stored, favorites and popular. However, it's still installs it as a theme. Odd.

That was one of the coolest things about personas, that ability to mouse over and select, now it's NOT FUN AT ALL, it's a drag and makes me not want to use them. Sad considering this is one of the things firefox is pushing **** their site and it doesn't work right for those who upgraded to 3.6

FF ver 3.6 (Problem began after upgrading to 3.6)
Windows Vista
Problem always
Problem in safe mode too
Uninstalled and reinstalled personas and nothing.
(That is about as far as I'm willing to go to make the pretty pictures work)

Comment 14

9 years ago
Someone (Tiribulus on MozillaZine) mentioned reverting back to an older version of the personas add on (1.4) and for mouse overs it worked perfect... Not sure about the themes and personas working together problem but he seemed to think it would work. Give it a go...

https://addons.mozilla.org/en-US/firefox/addons/versions/10900#version-1.4

Comment 15

9 years ago
For me this is still an issue and I wonder if anyone else it still having this problem?

Vista 32
Always default theme:
FF3.6
Personas 1.5.1 (No mouse over, wants to add personas -all personas- as themes with an Allow bar/button every time)

Reverted back to personas 1.4 and got mouseovers working again but every time I change my persona, the allow bar/button pops up again. I don't hit the allow but the persona changes and works fine.

I just wish I knew why this was going on with my computer

Comment 16

9 years ago
I've the same problem, and here's how I got it working again: 
Options | Security. Press the topmost button Exceptions. Add "http://www.getpersonas.com" to the list of allowed sites (my list was initially empty).

Perhaps an idea to "hardcode" this site as trusted?
(In reply to comment #16)
> I've the same problem, and here's how I got it working again: 
> Options | Security. Press the topmost button Exceptions. Add
> "http://www.getpersonas.com" to the list of allowed sites (my list was
> initially empty).
> 
> Perhaps an idea to "hardcode" this site as trusted?

The site is in the list in Firefox 3.6, along with addons.mozilla.org. Seems like the list was destroyed/cleared on upgrade?

Comment 18

6 years ago
Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/16.0 Firefox/16.0a1 (20120614075912)
This issue doesn't reproduce on the latest Nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [testday-20120615]
You need to log in before you can comment on or make changes to this bug.