Closed Bug 541313 Opened 10 years ago Closed 9 years ago

Changing image size using Custom Size changes the image but does not display the new height and width correctly -- H and W always equal the Actual Size

Categories

(SeaMonkey :: Composer, defect)

defect
Not set

Tracking

(seamonkey2.3 fixed, seamonkey2.4 fixed)

RESOLVED FIXED
seamonkey2.5
Tracking Status
seamonkey2.3 --- fixed
seamonkey2.4 --- fixed

People

(Reporter: rolson, Assigned: neil)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: 2.02

Right clicking on an JPEG image which is in a table, followed by selecting Image Properties brings up the Image Properties window.  Selecting the Dimensions tab allows changing the image size.  Selecting Custom Image allows changing the Width and Height  (with or without Constraining the format)
Changing the H or W and clicking OK does change the image size correctly

However, if the Dimensions window is displayed after the image size has been changed, the original size is displayed  -- which always equals the Actual Size

There is no way to know what the size of an image actually is after it has been changed

Reproducible: Always

Steps to Reproduce:
1.Right click on an JPEG image which is in a table, 
2.Select Image Properties - brings up the Image Properties window.  
3.Select the Dimensions tab
4.Select Custom Image box
5.Change the Width and/or Height
6.Click OK
7.Image size will change correctly
8.Right click on the image 
9.Select Image Properties   
10.Select the Dimensions tab
11. Note that the H and W values have not changes and the Actual Size option is now selected instead of the Custome Size option



However, if the Dimensions window is displayed after the image size has been changed, the original size is displayed  -- which always equals the Actual Size

There is no way to know what the size of an image actually is after it has been changed
2.
3.
Actual Results:  
H and W values of the changed image are not shown in the Dimensions window
Custom Size option has been changed back to Actual Size

Expected Results:  
H and W values should show actual changed image size
Custom Size option should still be selected

Same problem with Windows XP SP3 and Windows 7
Version: unspecified → SeaMonkey 2.0 Branch
This problem shows up in the 2010 versions of Composer, and was not there in the older versions (Seamonkey 1.1.18). 

The source code does show the custom size of the image. 

However the Image button in the tool bar (Dimensions tab) looses the values for Custom Size. Clicking the o.k.-button and leaving the imageproperties-window immediately changes the image to the actual size.
The same problem is reported in Bug 543216
Duplicate of this bug: 543216
In addition to the losing of the values for Image Custom Size, also the no-ALT-text-preference will be lost, every time the Image button in the tool bar is opened.

Working on a HTML-newsletter with a load of images this weekend I realized again the influence of this bug. Working with Composer has lost much of its pleasure, avoiding the use of the image button (because the custom values for height and width will be erased as soon as the image button will be opened). Practically I've decided to return to an older version of Seamonkey (1.1.18), because Composer has always been the main reason for using Seamonkey.
Duplicate of this bug: 630930
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86_64 → All
Version: SeaMonkey 2.0 Branch → Trunk
This is fallout from bug 371260 - Image Properties isn't expecting Actual Size to be selected by default.
Blocks: 371260
Before bug 371260, neither radiobutton was selected by default, so the code would consider selecting the actual size radiobutton, and if it decided against it it would select the custom size radiobutton. Bug 371260 made the actual size radiobutton selected by default, confusing the dialog into thinking that it had determined that the image was at its actual size. Making the custom size radiobutton selected by default removes the confusion. It also avoids having to subsequently select the custom size radiobutton.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #544786 - Flags: review?(iann_bugzilla)
Please also read Bug 630930 - Editing an image resets the dimensions to "Actual Size". This was declared a "Duplicate", and may have the same cause, but the symptoms are different. Please make sure that the symptoms of Bug 630930 are fixed before resolving this bug.
All three bugs (541313, 543216, 630930) look like variations on the same bug which is that when you open Image Properties then Actual Size is always selected, and that is what this patch is intended to address.
Comment on attachment 544786 [details] [diff] [review]
Proposed patch [Checkin: comments 11 and 14]

>+++ b/editor/ui/dialogs/content/EdImageOverlay.js	Fri Jul 08 13:28:49 2011 +0100
>@@ -406,7 +403,7 @@ function ChangeImageSrc()
> function doDimensionEnabling()
> {
>   // Enabled only if "Custom" is selected
Nit: Comment needs correcting?
>-  var enable = (gDialog.customSizeRadio.selected);
>+  var enable = !gDialog.actualSizeRadio.selected;
Attachment #544786 - Flags: review?(iann_bugzilla) → review+
Pushed changeset 2942fbea7496 to comm-central.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Comment on attachment 544786 [details] [diff] [review]
Proposed patch [Checkin: comments 11 and 14]

If it helps, only the XUL change is needed to work around the bug.
Attachment #544786 - Flags: approval-comm-beta?
Attachment #544786 - Flags: approval-comm-aurora?
Comment on attachment 544786 [details] [diff] [review]
Proposed patch [Checkin: comments 11 and 14]

a=me for both as no L10n changes and is a fix.
Attachment #544786 - Flags: approval-comm-beta?
Attachment #544786 - Flags: approval-comm-beta+
Attachment #544786 - Flags: approval-comm-aurora?
Attachment #544786 - Flags: approval-comm-aurora+
Keywords: checkin-needed
Whiteboard: [transplant c-c changeset 2942fbea7496 to c-a and c-b needed]
Comment on attachment 544786 [details] [diff] [review]
Proposed patch [Checkin: comments 11 and 14]

http://hg.mozilla.org/releases/comm-aurora/rev/4ad6cea2a306
http://hg.mozilla.org/releases/comm-beta/rev/98972adac7ef
Attachment #544786 - Attachment description: Proposed patch → Proposed patch [Checkin: comments 11 and 14]
Keywords: checkin-needed
Whiteboard: [transplant c-c changeset 2942fbea7496 to c-a and c-b needed]
Target Milestone: --- → seamonkey2.3
Target Milestone: seamonkey2.3 → seamonkey2.5
Duplicate of this bug: 356312
You need to log in before you can comment on or make changes to this bug.