[OOPP] Glitches when switching farmville to full-screen mode

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR
 0. Grab an e10s-latest build (ensure OOPP is enabled; it is by default)
 1. Go to farmville
 2. Press "full-screen" button at bottom right

I've seen two distinct glitches after 2.:

 A. Full-screen window doesn't "pop up"; instead last rendered frame of non-full-screen windowless farmville stays in the browser window.  The full-screen farmville window appears after I minimize all other open windows in the workspace.

 B. Full-screen window appears immediately, but after Alt-Tab switching to another full-screen application and then Alt-Tab switching back to Firefox, both the full-scree farmville window and the windowless box in-browser don't reappear.  The full-screen farmville window appears after I minimize all other open windows in the workspace.

Expected behavior (based on IPP farmville and youtube):
 Full-screen window appears immediately.  Alt-Tab switching to another full-screen application makes the full-screen flash window go away.  Alt-Tab switching back into firefox shows flash back in non-full-screen mode.

It seems to me that these are symptoms of the same underlying problem, which seems to be a timing issue.

I wasn't able tried to repro these symptoms with full-screen youtube videos.  Perhaps this is a flash bug?

Tentatively set to block OOPP beta, but if it's a flash bug it doesn't.
I can't repro either glitch 100% faithfully, but both happen quite frequently, probably >50% of full-screen switches.
I'm not running Linux, but on Win7 Pro x64 with the latest Flash 10.1 beta and OOPP enabled, I'm seeing a lot of glitches when a Flash object is open in 1 tab and I switch tabs or move from fullscreen to windowed. As soon as I go back the latest Flash 10.0 release, the glitches disappear.
Oh, forgot to add --- I saw the glitches with Flash 10.0 r42 x86-64.
I can't repro this anymore.  I suspect karlt fixed this incidentally.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Maybe GDK_NATIVE_WINDOWS could have helped here.
Hooking that up as a dependency so we can check this if we ever remove GDK_NATIVE_WINDOWS.
Depends on: 535612
You need to log in before you can comment on or make changes to this bug.