Closed Bug 541673 Opened 12 years ago Closed 12 years ago

Whenever the Options Window is opened, the default download folder is created again if it doesn't exist.

Categories

(Firefox :: Preferences, defect)

3.6 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 474718

People

(Reporter: underpass_bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.2) Gecko/20100115 Firefox/3.6

On Windows XP Firefox 3.6 creates again the default My Documents\Download (that is C:\Documents and settings\<username>\Documents\Download) even if the download folder has been redirected elsewhere.

Reproducible: Always

Steps to Reproduce:
1.With a new profile, open Firefox and then open the Options Window.
2.In the "Download" section of the general panel set another folder as the default destination for downloads (e.g. C:\Download)
3.Open Windows Explorer and delete the My Documents\Download folder
4.Open again the Options Window in Firefox
5.Open My Documents folder in Windows Explorer
Actual Results:  
You'll find that there is again a folder named Download.

Expected Results:  
No default folder should be created if the download folder is set by the user.

The problem has been reported by a user in the Italian support forum and confirmed by a user in the Mozilla #sumo irc channel and seems to happen both in new installations and in upgrades from 3.5.7.
It seems to occur only in Windows XP (not in Windows 7 nor in Vista).
Summary: Whenever the options window is opened, the default download folder is created again. → Whenever the Options Window is opened, the default download folder is created again.
Summary: Whenever the Options Window is opened, the default download folder is created again. → Whenever the Options Window is opened, the default download folder is created again if it doesn't exist.
Component: General → Preferences
QA Contact: general → preferences
Version: unspecified → 3.6 Branch
Duplicate of Toolkit bug 476311 -> Toolkit bug 474718.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474718
You need to log in before you can comment on or make changes to this bug.