[SeaMonkey 2.1] xpcshell: test_download_history.js and test_frecency.js fail, after bug 520165 landing

VERIFIED FIXED in seamonkey2.1a1

Status

SeaMonkey
Download & File Handling
--
major
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: sgautherie, Assigned: Robert Kaiser)

Tracking

(Blocks: 1 bug)

Trunk
seamonkey2.1a1
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
We fixed this test a year ago in bug 470707.
It now needs bug 520165 to be (fully) ported:
bug 536374 will fix this, but I file this separately due to ongoing test infrastructure changes...

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1264295815.1264297689.4981.gz&fulltext=1
Linux comm-central-trunk debug test xpcshell on 2010/01/23 17:16:55
{
TEST-UNEXPECTED-FAIL | test_download_history.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | test_download_history.js | true == false - See following stack:

JS frame :: xpcshell/head.js :: do_throw :: line 202
JS frame :: xpcshell/head.js :: do_check_eq :: line 232
JS frame :: xpcshell/head.js :: do_check_false :: line 251
JS frame :: test_download_history.js :: test_dh_disabledHistory :: line 122
JS frame :: test_download_history.js :: run_test :: line 154
JS frame :: xpcshell/head.js :: _execute_test :: line 130
JS frame :: -e :: <TOP_LEVEL> :: line 1
}

Code is
{
122   do_check_false(observer.topicReceived);
}

I reproduce this on my local non-packaged Windows opt build.
(Reporter)

Comment 1

8 years ago
test_frecency.js is in a "same" case.
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/tests/unit/test_frecency.js
Summary: [SeaMonkey 2.1] xpcshell: test_download_history.js fails again → [SeaMonkey 2.1] xpcshell: test_download_history.js and test_frecency.js fail, after bug 520165 landing
(Reporter)

Updated

8 years ago
Summary: [SeaMonkey 2.1] xpcshell: test_download_history.js and test_frecency.js fail, after bug 520165 landing → [SeaMonkey trunk] xpcshell: test_download_history.js and test_frecency.js fail, after bug 520165 landing
(Reporter)

Updated

8 years ago
Blocks: 470184
(Reporter)

Comment 2

8 years ago
As expected per bug 536374 comment 27:
*test_download_history.js is fixed.
*test_frecency.js still fails.

{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1266513354.1266514667.21677.gz&fulltext=1
Linux comm-central-trunk debug test xpcshell on 2010/02/18 09:15:54

Test 8.1: same count, same date
TEST-PASS | tests/test_places/unit/test_frecency.js | [anonymous : 123] 1 == 1
TEST-PASS | test_places/unit/test_frecency.js | [anonymous : 127] 1 == 1
TEST-UNEXPECTED-FAIL | test_places/unit/test_frecency.js | 3 == 4 - See following stack:
JS frame :: xpcshell/head.js :: do_throw :: line 202
JS frame :: xpcshell/head.js :: do_check_eq :: line 232
JS frame :: test_places/unit/test_frecency.js :: anonymous :: line 129
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
JS frame :: seamonkey/components/nsPlacesAutoComplete.js :: PAC_notifyResults :: line 643
JS frame :: seamonkey/components/nsPlacesAutoComplete.js :: PAC_finishSearch :: line 590
JS frame :: seamonkey/components/nsPlacesAutoComplete.js :: PAC_handleCompletion :: line 501
JS frame :: seamonkey/components/nsPlacesAutoComplete.js :: ACSCW_handleCompletion :: line 176
}
Summary: [SeaMonkey trunk] xpcshell: test_download_history.js and test_frecency.js fail, after bug 520165 landing → [SeaMonkey 2.1] xpcshell: test_download_history.js and test_frecency.js fail, after bug 520165 landing
(Reporter)

Updated

8 years ago
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)

> TEST-UNEXPECTED-FAIL | test_places/unit/test_frecency.js | 3 == 4 - See
> following stack:
> JS frame :: test_places/unit/test_frecency.js :: anonymous :: line 129
> native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

It looks like we're getting "no match" instead of "match":
http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/components/autocomplete/public/nsIAutoCompleteController.idl?mark=52-53#43

Ftr, we have some prefs at
http://mxr.mozilla.org/comm-central/source/suite/browser/browser-prefs.js#135
but not sure it is relevant in this case.
(Reporter)

Comment 4

7 years ago
MacOSX too:
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1266802005.1266803746.19182.gz
OS X 10.5 comm-central-trunk debug test xpcshell on 2010/02/21 17:26:45
}
(Reporter)

Comment 5

7 years ago
KaiRo, could you check this test?
(Hopefully, it's a preference issue as we're used to.)
(Assignee)

Comment 6

7 years ago
Created attachment 433061 [details] [diff] [review]
fix test_frecency.js to work on SeaMonkey

test_download_history.js passes right here, perhaps it's a followup failure from something else or it's fixed by some of the other patches I have in my tree.
test_frecency.js needs the prefs set correctly apparently, though, this is a patch to apply the same fixes as I did on other tests, see e.g. http://hg.mozilla.org/mozilla-central/annotate/11798edae90d/toolkit/components/places/tests/unit/test_history_autocomplete_tags.js#l189
Attachment #433061 - Flags: review?(dietrich)
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> test_download_history.js passes right here

Yes, see comment 2.
Assignee: nobody → kairo
No longer blocks: 470184
Status: NEW → ASSIGNED
Flags: in-testsuite+
Attachment #433061 - Flags: review?(dietrich) → review+
(Assignee)

Comment 8

7 years ago
Pushed as http://hg.mozilla.org/mozilla-central/rev/1110220cedd4 - I think that should fix this.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

7 years ago
V.Fixed per tinderboxes.
Status: RESOLVED → VERIFIED
Depends on: 520165
You need to log in before you can comment on or make changes to this bug.