Last Comment Bug 541761 - Some text implies the Firefox logo is under a non-free copyright license
: Some text implies the Firefox logo is under a non-free copyright license
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Gervase Markham [:gerv]
:
:
Mentors:
http://weblogs.mozillazine.org/gerv/a...
Depends on:
Blocks: 541984
  Show dependency treegraph
 
Reported: 2010-01-23 21:17 PST by James Andrewartha
Modified: 2010-07-13 09:05 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v.1 (2.17 KB, patch)
2010-02-01 08:16 PST, Gervase Markham [:gerv]
no flags Details | Diff | Splinter Review
Patch B, v.1 (3.09 KB, patch)
2010-03-11 03:32 PST, Gervase Markham [:gerv]
kairo: review+
Details | Diff | Splinter Review

Description James Andrewartha 2010-01-23 21:17:00 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.19) Gecko/20081204 Iceape/1.1.14 (Debian-1.1.14-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.19) Gecko/20081204 Iceape/1.1.14 (Debian-1.1.14-1)

Apparently when the Firefox binary was changed to being distributed under the MPL, this include the icons too. However, no documentation was changed to reflect this, nor was a specific announcement that the logo now had a free copyright license made.http://weblogs.mozillazine.org/gerv/archives/2010/01/packages_and_trademarks_an_observation.html

Reproducible: Always

Steps to Reproduce:
1. Look for the license on the Firefox logo
Actual Results:  
other-licenses/branding/firefox/LICENSE says "You are not granted rights or licenses to the trademarks of the Mozilla Foundation or any party, including without limitation the Firefox name or logo." which to me implies copyright and trademark licenses.

about:rights says "Mozilla does not grant you any rights to the Mozilla and Firefox trademarks or logos."

Expected Results:  
It says something like "The logos' copyright is licensed under the MPL/LGPL/GPL, but use is also subject to trademark licensing". about:rights says the same thing in respect to the logos.

Gerv has changed http://www.mozilla.org/MPL/license-policy.html to reflect the above, but apparently further changes require a bug, so here we are.
Comment 1 Gervase Markham [:gerv] 2010-01-28 07:41:29 PST
I've moved this bug to the Legal component so the right people see it - although that seems to mandatorily hide it from public view, which is rather unfortunate.

Gerv
Comment 2 Mike Beltzner [:beltzner, not reading bugmail] 2010-01-28 14:09:47 PST
I'm confused by the report. There's a difference between the license by which the icons and image files are governed, and the trademarked logos that are part of the Firefox branding. Presumably you're just talking about the branding?

I'm further confused by the request; but I've never been too good at the legal stuff. The binary forms of the images aren't under MPL, are they? The final binary that is produced is MPL, which is detailed in about:rights, but the specific logo files are goverened by the LICENSES file in the /other-licenses directory which correctly indicates that they are trademarked items.

Harvey: is that right?

(Gerv: if you want legal people to see it, but it's not a bug that requires confidentiality, you can cc: the legal team. However, Harvey's legal advice must be considered privileged for legal reasons, which is why the component is default-restricted)
Comment 3 Gervase Markham [:gerv] 2010-01-28 14:51:32 PST
Mike: thanks for the clarification on component structure.

I'm talking about the copyright licence which applies to the ones and zeroes which make up the image files which depict the Firefox logo.

When we took the decision to ship the official binaries under the MPL, we also decided to make the logo bits MPLed. That was an inevitable consequence; if a binary distribution of Firefox is MPLed, that means all the files in it are MPLed, and can be used under those terms. The non-MPLed non-free-software nature of the logo bits was one of the things the Linux distributions didn't like (and rightly so).

Of course, this doesn't give anyone the right to use our trademarks in a way trademark law forbids. 

This bug is about the fact that we haven't updated various bits of documentation to make this clear. The practical effect of that is that the FUD about Firefox being "non-free" can still do the rounds. We don't want to give people sticks to beat us with for no reason; we should fix the docs to match the current legal position.

Gerv
Comment 4 Gervase Markham [:gerv] 2010-01-29 13:16:34 PST
A clarification, as requested by luis: all I wanted by moving this bug with legal is to make you guys aware that we're doing this, and give you a chance to object if you see a problem I haven't foreseen. If there are no such issues, I'll go ahead and fix it :-)

Gerv
Comment 5 harvey anderson 2010-01-29 18:24:24 PST
Understood. Please, please go ahead and fix.
Comment 6 Gervase Markham [:gerv] 2010-02-01 08:16:36 PST
Created attachment 424602 [details] [diff] [review]
Patch v.1

Harvey: is this OK?

Gerv
Comment 7 Gervase Markham [:gerv] 2010-02-01 08:22:33 PST
Comment on attachment 424602 [details] [diff] [review]
Patch v.1

I've moved this bug back out of Legal so it can be seen again.

Gerv
Comment 8 James Andrewartha 2010-02-01 08:40:14 PST
toolkit/locales/en-US/chrome/global/aboutRights.dtd and possibly toolkit/content/aboutRights.xhtml also need updating.
Comment 9 harvey anderson 2010-02-01 17:35:52 PST
This is ok.
Comment 10 Reed Loden [:reed] (use needinfo?) 2010-02-24 20:47:04 PST
Comment on attachment 424602 [details] [diff] [review]
Patch v.1

>-You are not granted rights or licenses to the trademarks of the
>+These files are under the tri-license, as below. However, please note that you are not granted any trademark rights or licenses to the trademarks of the
> Mozilla Foundation or any party, including without limitation the
> Firefox name or logo.

Please word-wrap the first line. It currently looks very awkward with your change.
Comment 11 Gervase Markham [:gerv] 2010-02-25 05:31:42 PST
Done in my local copy; thanks. Still waiting for a green tree...

Gerv
Comment 12 Gervase Markham [:gerv] 2010-03-08 08:33:29 PST
hg commit -u ''  other-licenses/branding/firefox/LICENSE
other-licenses/branding/firefox/LICENSE
committed changeset 39109:99d80bc3f18b

http://hg.mozilla.org/mozilla-central/rev/99d80bc3f18b

Gerv
Comment 13 Mike Hommey [:glandium] 2010-03-08 10:48:39 PST
By the way, what about the other brandings ? (seamonkey, thunderbird, sunbird...)
Comment 14 Gervase Markham [:gerv] 2010-03-10 05:46:53 PST
Mike: all the same. Ones and zeroes are MPLed, images are a trademark. (Although the scope of trademark registration varies from logo to logo.)

(In reply to comment #8)
> toolkit/locales/en-US/chrome/global/aboutRights.dtd and possibly
> toolkit/content/aboutRights.xhtml also need updating.

I don't think so... where exactly?

Gerv
Comment 15 James Andrewartha 2010-03-10 07:03:52 PST
(In reply to comment #14)
> (In reply to comment #8)
> > toolkit/locales/en-US/chrome/global/aboutRights.dtd and possibly
> > toolkit/content/aboutRights.xhtml also need updating.
> 
> I don't think so... where exactly?

http://mxr.mozilla.org/mozilla-central/source/toolkit/locales/en-US/chrome/global/aboutRights.dtd#19 says:

<!ENTITY rights.intro-point2a "Mozilla does not grant you any rights to the Mozilla and Firefox trademarks or logos. Additional information on Trademarks may be found ">
Comment 16 Gervase Markham [:gerv] 2010-03-10 07:54:15 PST
That statement is correct, albeit it would be clearer if it said "trademark rights" rather than just "rights". But there are no other sorts of right attached to a trademark or logo - copyright applies to a particular expression of that trademark or logo.

Gerv
Comment 17 James Andrewartha 2010-03-10 08:00:01 PST
Yes, but it's the same change I asked for and you made to the branding license file:

-You are not granted rights or licenses to the trademarks of the
+These files are under the tri-license, as below. However, please note that you are not granted any trademark rights or licenses to the trademarks of the
 Mozilla Foundation or any party, including without limitation the
 Firefox name or logo.
Comment 18 Mike Hommey [:glandium] 2010-03-10 08:02:02 PST
(In reply to comment #16)
> That statement is correct, albeit it would be clearer if it said "trademark
> rights" rather than just "rights". But there are no other sorts of right
> attached to a trademark or logo - copyright applies to a particular expression
> of that trademark or logo.

I'd say removing "or logos" in the phrase would be enough to make it less ambiguous: "Mozilla does not grant you any rights to the Mozilla and Firefox trademarks."
Comment 19 harvey anderson 2010-03-10 09:34:38 PST
1) If its just trademarks, some readers may not know exactly what elements (word marks, trade names, graphic designs, logos) are considered trademarks, thus the inclusion of "logo" in my view actually makes it more clear and removes any doubt. 

2) the point about there being no other sorts of rights is true. That could be fixed by deleting "trademark" as shown below in brackets. 

"These files are under the tri-license, as below. However, please note that you
are not granted any [trademark] rights or licenses to the trademarks of the
 Mozilla Foundation or any party, including without limitation the
 Firefox name or logo.
Comment 20 Gervase Markham [:gerv] 2010-03-10 09:38:18 PST
Harvey: did you mean "adding" rather than "deleting" in your point 2)? If not, I don't quite understand you... The current version does not have that word; the version I updated other-licenses/branding/firefox/LICENSE to, as quoted in comment 17, does have it.

Gerv
Comment 21 harvey anderson 2010-03-10 10:01:31 PST
I meant delete - so if its already gone - great. I was referring to the language in comment 17.
Comment 22 Gervase Markham [:gerv] 2010-03-10 10:10:49 PST
Harvey: we seem to have got into a muddle :-(

The first change made in this bug was (in part) to change:

a) You are not granted rights or licenses to the trademarks of the
   Mozilla Foundation or any party, including without limitation the
   Firefox name or logo.

into 

b) you are not granted any trademark rights or licenses to the trademarks of the
   Mozilla Foundation or any party, including without limitation the
   Firefox name or logo.

This change has already been made. Now, someone is proposing a second change in a different file. That would be to change:

c) Mozilla does not grant you any rights to the Mozilla and Firefox trademarks or logos. Additional information on Trademarks may be found...

into 

d) Mozilla does not grant you any trademark rights to the Mozilla and Firefox trademarks or logos. Additional information on Trademarks may be found...

- Was the first change correct, or does it need further work?
- Do you agree with the second change?

Gerv
Comment 23 harvey anderson 2010-03-10 11:27:08 PST
As a general observation - we're talking about minor differences so neither version is fundamentally problematic.

-The first change (b) - was correct.  

-The second change (d) should be reworded as either:


"Mozilla does not grant you any rights or licenses to use the Mozilla and Firefox trademarks or logos."

or 

make it the same as the language in (b). (my preference)

thanks for parsing this.
Comment 24 Gervase Markham [:gerv] 2010-03-11 03:32:24 PST
Created attachment 431830 [details] [diff] [review]
Patch B, v.1

OK, here it is. This touches code, so I should get a review of some sort. KaiRo helped me with the entity names, and no good deed goes unpunished :-)

Gerv
Comment 25 Robert Kaiser 2010-03-11 08:47:20 PST
Comment on attachment 431830 [details] [diff] [review]
Patch B, v.1

It's somewhat unfortunate that we are talking about "Firefox" explicitely in a toolkit file and need to override it from every other app, but I guess that's just the way it is.

The patch itself looks good to me.
Comment 26 [:Aleksej] 2010-03-15 03:36:23 PDT
Does the tri-license apply only to the current logo versions, or also to the pre-Firefox3.5 ones? Thanks.
Comment 27 Gervase Markham [:gerv] 2010-03-15 04:34:52 PDT
Aleksej: why do you ask?

Gerv
Comment 28 [:Aleksej] 2010-03-15 04:48:39 PDT
(In reply to comment #27)

Wikimedia Commons accepts trademarked files under free copyright licenses.
http://commons.wikimedia.org/wiki/Category:Mozilla_Firefox contains a warning ("Do not upload any Firefox or Thunderbird logos to the Commons"),
and there are http://commons.wikimedia.org/wiki/Category:Screenshots_of_Mozilla_Firefox some of which are uploaded with logos (and are deleted or edited sometimes because of that).
How should that be changed?

Less relevant: this image http://commons.wikimedia.org/wiki/File:Jlilly3.jpg has been cropped so that the logo is de-minimis (out of focus, not the main subject, and can be ignored, so the whole image is not considered non-free). Would that logo be under the tri-license at that quality?
Comment 29 Gervase Markham [:gerv] 2010-03-15 05:00:17 PDT
> http://commons.wikimedia.org/wiki/Category:Mozilla_Firefox contains a warning

The text on that page suggests that photos are not acceptable in the commons if any part of the photo includes a copyrighted logo. Is that really true? They seem to think copyright works like trademark, but it doesn't. 

> Would that logo be under the tri-license at that quality?

And you seem to think copyright works like trademark too :-(

The _logo_ is restricted by trademark law - you can't do certain things with it, like putting it on a web browser. This applies to copies of the logo you got from us, copies of the logo which you photographed, and copies of the logo you created yourself from scratch using Inkscape. This is also true of the trademarked logo of every other company and product in the world, in whichever jurisdictions the trademark is registered - and some where it isn't, because in some places, just using a logo qualifies it for protection.

The _logo_files_ for the Firefox 3.5 logo are free software - available under your choice of the MPL, LGPL or GPL copyright licences. This applies only to the copies available from us. If someone were to independently draw the Firefox logo in Inkscape, they could put whatever copyright licence they liked on their file. (Probably. There's the question of whether it would be a derivative work anyway, but let's ignore that for the moment.)

This means that the copyright in the Lilly photo is owned by whoever took it, and they can licence it how they like - whether our logo is in it or not.

Gerv
Comment 30 [:Aleksej] 2010-03-15 05:26:40 PDT
(In reply to comment #29)

Whether screenshots with small logos in them are acceptable has been disputed, but no stand-alone logo has been kept, because Wikimedia Commons (do not confuse with Wikipedia)) is for freely licensed media (what about a screenshot full of non-free logos?).

_What if a Firefox 1.5 logo is uploaded?_



> file. (Probably. There's the question of whether it would be a derivative work
> anyway, but let's ignore that for the moment.)

That's an important question.
http://commons.wikimedia.org/wiki/Commons:Derivative_works
http://commons.wikimedia.org/wiki/Commons:Fan_art

> This means that the copyright in the Lilly photo is owned by whoever took it,
> and they can licence it how they like - whether our logo is in it or not.

What if I crop the photo, so the logo is in the middle, and release the result into the public domain? Will only the trademark rights be left? According to Commons (AFAIK), it will, first of all, be a derivative work.
Photos are considered different from screenshots, though, so "de minimis" ("the image may stay, and is under that free license as a whole, but if you crop it, you can get a non-free image") is more accepted for them.
Comment 31 Gervase Markham [:gerv] 2010-03-17 04:12:10 PDT
The new terms don't apply to older logos. This is not a specific decision we've made - it's just that we haven't gone back and done anything to retroactively relicense them.

I find it hard to understand how Wikimedia Commons can define any photo of a Coke can as automatically non-free, with no way to make it free. But I guess that's up to them.

Gerv
Comment 32 James Andrewartha 2010-03-17 04:19:08 PDT
http://www.chillingeffects.org/copyright/faq.cgi#QID809 "A photograph of a copyrighted item is considered a derivative work in US jurisdiction."
Comment 33 Mike Hommey [:glandium] 2010-03-17 04:20:20 PDT
(In reply to comment #31)
> The new terms don't apply to older logos.

If you consider the test suite files as being tri-licensed, then there are versions of the older logos that are de-facto tri-licensed ;)
Comment 34 Mike Hommey [:glandium] 2010-03-22 12:27:20 PDT
I'm wondering, if the logos are tri-licensed, now, shouldn't they be moved outside other-licenses (probably in browser/branding/official) ?

Also, shouldn't the LICENSE files for thunderbird and sunbird branding in comm-central be changed, too ?
Comment 35 Gervase Markham [:gerv] 2010-04-21 09:38:23 PDT
(In reply to comment #34)
> I'm wondering, if the logos are tri-licensed, now, shouldn't they be moved
> outside other-licenses (probably in browser/branding/official) ?

In an ideal world, but it would probably break something. If you want to file a bug, feel free, but I don't know who would fix it.

> Also, shouldn't the LICENSE files for thunderbird and sunbird branding in
> comm-central be changed, too ?

Could you file a new bug for that, please?

This bug, as stated, is fixed.

Gerv
Comment 36 Gervase Markham [:gerv] 2010-04-21 09:39:54 PDT
Oh, OK, no it's not. I still need to check in attachment 431830 [details] [diff] [review].

(It would be easier to see whether it was or not, if this bug were on a single topic...)

Gerv
Comment 37 Gervase Markham [:gerv] 2010-04-28 03:37:37 PDT
Attachment 431830 [details] [diff] checked in.
http://hg.mozilla.org/mozilla-central/rev/57d57ecce06b

Gerv

Note You need to log in before you can comment on or make changes to this bug.