If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Removal of dependentlibs.list breaks Prism on OS X

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Core
Build Config
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Matthew Gertner, Assigned: Matthew Gertner)

Tracking

({regression})

Trunk
mozilla1.9.3a1
x86
Mac OS X
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(status1.9.2 .7-fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

8 years ago
When Prism for Firefox (i.e. the extension) is used to create a Prism app on OS X, it uses the XUL runtime from Firefox for the app so that it doesn't have to be duplicated on disk. I do this by setting GRE_HOME to point to Firefox.app/Contents/MacOS.

This worked fine in Firefox 3.5, but in 3.6 the file dependentlibs.list has been removed from the distribution (see https://bugzilla.mozilla.org/show_bug.cgi?id=463605#c13). This prevents our stub (based on the XULRunner stub) from loading the XUL libraries.

I guess this problem is fairly specific to Prism since I doubt anyone else is using the Firefox runtime in this way. If there's a better way to accomplish this that I didn't think of, please let me know. Otherwise I'll post a patch putting that file back into the dist on OS X.
Just patch it back. I didn't realize that removing it would break things, obviously, since it was missing from the Win32 packaging manifest (apparently it's not required there).

You should just have to add it back to package-manifest.in, and remove it from removed-files.in.
And not ifdeffed for just OS X - I finally got curious enough about it to ask bsmedberg a while back, and he said we should have been shipping it on all platforms all along (ifdef libxul, back in the days when we would package something that wasn't libxul), but I ignored the part where he said it would be too much trouble to not generate it for non-libxul builds, and got stuck trying to make that work.
(Assignee)

Comment 3

8 years ago
Created attachment 423389 [details] [diff] [review]
Put dependentlibs.list into the manifest
Attachment #423389 - Flags: review?(ted.mielczarek)
Comment on attachment 423389 [details] [diff] [review]
Put dependentlibs.list into the manifest

As philor points out, that should probably be inside #ifdef MOZ_LIBXUL.

r=me with that change.
Attachment #423389 - Flags: review?(ted.mielczarek) → review+
By which Ted means "why does philor always confuse things with issues from his silly non-libxul app? you only get into Firefox's package-manifest if you are MOZ_LIBXUL, so there's no need for an ifdef here."
Assignee: nobody → matthew.gertner
Pushed to m-c:
http://hg.mozilla.org/mozilla-central/rev/61e445047db6
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Comment on attachment 423389 [details] [diff] [review]
Put dependentlibs.list into the manifest

We should get this into 3.6.1, it broke Prism and it's an accidental regression.
Attachment #423389 - Flags: approval1.9.2.1?
Blocks: 463605
Keywords: regression
Blocks: 535342
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.3a1
Version: unspecified → Trunk
(Assignee)

Comment 8

8 years ago
Does target milestone 1.9.3a1 mean this won't get into FF 3.6?
No, it's generally just used to mean "this landed in 1.9.3a1". The patch is up for approval for 1.9.2.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 513628
Attachment #423389 - Flags: approval1.9.2.2? → approval1.9.2.3?
(Assignee)

Updated

8 years ago
Duplicate of this bug: 557004

Comment 12

8 years ago
Pardon the clarification request, but I just reported this as Bug 557007 wrt FF 3.6.3 (MacOS X) and it is classified as a duplicate. Is this patch still pending acceptance in a future public update? If the patch is included in ff 3.6.3 something else is wrong

Comment 13

8 years ago
(In reply to comment #12)
> Pardon the clarification request, but I just reported this as Bug 557007 wrt FF
> 3.6.3 (MacOS X) and it is classified as a duplicate. Is this patch still
> pending acceptance in a future public update? If the patch is included in ff
> 3.6.3 something else is wrong

Sorry "Prism broken" reported as Bug513628 and marked as dup...
(Assignee)

Comment 14

8 years ago
Yeah, we're waiting for approval so this fix can be included into an official Firefox release. It looks like we're hoping to get approval for Gecko 1.9.2.4 which means it would be in Firefox 3.6.4 (someone please correct me if I'm wrong about that).

Comment 15

8 years ago
(In reply to comment #14)
> Yeah, we're waiting for approval so this fix can be included into an official
> Firefox release. It looks like we're hoping to get approval for Gecko 1.9.2.4
> which means it would be in Firefox 3.6.4 (someone please correct me if I'm
> wrong about that).

Thanks! I'll post a brief note on the workaround and fix to the Prism Reviews page where a number of people been frustrated by this problem. Any Prism developer folk chiming in on issues like this occasionally would be helpful. I *really* like using Prism and hate to see it get a bad rep it does not deserve.

Comment 16

8 years ago
Comment on attachment 423389 [details] [diff] [review]
Put dependentlibs.list into the manifest

a=LegNeato for 1.9.2.5. Please ONLY land this on mozilla-1.9.2 default, as we
are still working on 1.9.2.4 on the relbranch
Attachment #423389 - Flags: approval1.9.2.4? → approval1.9.2.5+
(Assignee)

Comment 17

7 years ago
Created attachment 453369 [details] [diff] [review]
Same patch with user, title, etc. set

I followed the instructions at http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed. I guess whoever is committing this should use this patch.
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Attachment #423389 - Flags: approval1.9.2.5+ → approval1.9.2.6+
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/a34de5780b91
status1.9.2: --- → .6-fixed

Updated

7 years ago
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.