Scrolling hangs on digg.com comments When Zoomed in 2-3 steps

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
2 months ago

People

(Reporter: jmjeffery, Unassigned)

Tracking

({perf, regression})

Trunk
x86
Windows 7
perf, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

Visit www.digg.com and find a story with lots of comments. 
click on the comments link and as soon as the page starts to load try scrolling.  There is no, or very poor scrolling until the page is fully loaded.

Scrolling method seems to not matter, all are affected, mouse-wheel, down arrow or grabbing the scroll-bar and dragging.

This regressed with landing of:
https://bugzilla.mozilla.org/show_bug.cgi?id=526394
Forgot to add that the release version 3.6 does not exhibit this problem.

system spec: Athlon AMD x-4 Phenom quad-core, 8gig RAM, hd3200 onboard video.
Blocks: 526394
Keywords: regression
Just tried a zip-build of today's nightly m-c and I didn't see the lag on my system at work.  It then dawned on me, that at home, with my wide-screen monitor and my old eyes that I have to zoom at least 2 steps, or 3..  
Will retest when I get home from work with zooming set to 'normal'.

Comment 3

9 years ago
I can confirm this behavior but only after I click the link to expand all comments.  I tested on a story with over 200 comments.
Seems to be zoom related, there is some lag with normal zoom (no zoom), but its the same lag as with 3.6
> Visit www.digg.com and find a story with lots of comments.

Please provide example URL(s)
This one will show the problem, at least for me:
http://www.greenerbuildings.com/news/2010/01/28/majority-americans-still-dark-about-federal-phaseout-traditional-bulbs

click on the comments, 200+ of them and try to scroll as soon as the page starts to load.  To really see if issue, you have to zoom in at least 2 or 3 times.  

I see a log with normal page settings, but due to my old eyes, I have to zoom in, and that old bug of poor zoom performance will rear its head.  

I will change to title to reflect that zoom in required
Summary: Scrolling hangs on digg.com comments → Scrolling hangs on digg.com comments When Zoomed in 2-3 steps
> click on the comments

Where?  I clicked the link "Comment" above the article text, which takes
me to a new page http://www.greenerbuildings.com/node/32062/talk
which shows me three comments.
(In reply to comment #7)
> > click on the comments
> 
> Where?  I clicked the link "Comment" above the article text, which takes
> me to a new page http://www.greenerbuildings.com/node/32062/talk
> which shows me three comments.

Sorry, try this one: 
http://digg.com/world_news/J_D_Salinger_has_died_at_91

This this open directly with the comments loading, try scrolling during page load.
blocking2.0: --- → ?
Keywords: perf
Anybody still seeing this?
20160502172042 Mozilla/5.0 (Windows NT 6.1; rv:46.0) Gecko/20100101 Firefox/46.0
20160605030215 Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

I have tested your issue on latest FF release 46.0.1 and latest Nightly build and could not reproduce it.

Is this still reproducible on your end ? If yes, can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
Flags: needinfo?(jmjeffery)
No, I can no longer reproduce this problem.  I've not been to 'digg' in several years, and they have changed the layout from what I recall it being.

This can be closed..
Flags: needinfo?(jmjeffery)
Thanks.

Based on Comment 11 from the reporter, changing status to RESOLVED WORKS FOR ME.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 months ago
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.