History pane changes view when middle clicking links (regression from bug 498130)

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: stechz, Assigned: mano)

Tracking

({regression})

3.6 Branch
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
1. Go to History -> Show All History
2. Click yesterday and middle click an entry.

Unexpected: A few seconds later it takes me back to "Today" with an updated history.

Expected: history pane stays on yesterday so I can click other links.
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20100126 Minefield/3.7a1pre
This worked different with Firefox 3.5.
Keywords: regression
Keywords: regressionwindow-wanted
Regression window:

works:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091001 Minefield/3.7a1pre
2009-10-01-04-mozilla-central

broken:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091002 Minefield/3.7a1pre
2009-10-02-04-mozilla-central
based upon the range mentioned in comment 2 i presume this is caused by Bug 498130.
Blocks: 498130
Keywords: regressionwindow-wanted
Comparing latest trunk to branch 3.5 (build below), middle click behaves differently in multiple ways.

To clarify which issue the regression range tracks:

Works when the history pane stays on "Yesterday".
Broken when the history pane switches to "Today" after a few seconds.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1pre) Gecko/20090601 Shiretoko/3.5pre
Assignee: nobody → mano
Status: NEW → ASSIGNED
Summary: History pane changes view when middle clicking links → History pane changes view when middle clicking links (regression from bug 498130)
I'm almost sure this got fixed by the patch for bug 566613, which has already landed.  Can you confirm?
Works correctly for me.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100531 Minefield/3.7a5pre
Great!
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Depends on: 566613
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.