Ctrl+Shift+R causes the browser to crash [@ strlen | NS_strdup(char const*) ]

VERIFIED DUPLICATE of bug 540566

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 540566
8 years ago
8 years ago

People

(Reporter: Vasili Sviridov, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

While developing a site I constantly use Ctrl+Shift+R to refresh the page w/o using cached data. In firefox 3.6 that occasionally crashes the entire browser.

Reproducible: Sometimes

Steps to Reproduce:
Load a page
Press Ctrl+Shift+R
Actual Results:  
Occasionally entire browser crashes

Expected Results:  
Page should get reloaded without using cached data

It seems like it attempts to start reloading and crashes after.

There are currently Firebug, Adblock +, Personas and Flash player engaged.

Comment 1

8 years ago
Post crash IDs for this:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
Version: unspecified → 3.6 Branch

Comment 3

8 years ago
bp-81493a84-1aa3-414a-9aae-857c12100203
0  	mozcrt19.dll  	strlen  	 strlen.asm:81
1 	xul.dll 	NS_strdup 	obj-firefox/xpcom/build/nsCRTGlue.cpp:145
2 	xul.dll 	nsCacheEntryDescriptor::GetDeviceID 	netwerk/cache/src/nsCacheEntryDescriptor.cpp:98
3 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
4 	xul.dll 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2721
5 	xul.dll 	XPC_WN_GetterSetter 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1784
6 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1360
7 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1423
8 	js3250.dll 	js_GetPropertyHelper 	js/src/jsobj.cpp:4277
9 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:1520
10 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1368
11 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1696
12 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:570
13 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
14 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
15 	xul.dll 	nsCacheListenerEvent::Run 	netwerk/cache/src/nsCacheService.cpp:1094
16 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
17 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
18 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:182
19 	nspr4.dll 	PR_GetEnv 	
20 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:120
21 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
22 	kernel32.dll 	BaseProcessStart 

Appears to be bug 540566. Firebug seems involved; see bug 540566 comment 6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Summary: Ctrl+Shift+R causes the browser to crash → Ctrl+Shift+R causes the browser to crash [@ strlen | NS_strdup(char const*) ]
Duplicate of bug: 540566

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.