Closed Bug 542387 Opened 10 years ago Closed 10 years ago

Intermittent failure in test_bug541420.js | File should have been executable, permissions were 644

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

I was willing to give it the benefit of the doubt the first time, since things were burning and waiting on backouts and whatnot, but:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264519985.1264521223.23972.gz
Linux mozilla-central opt test xpcshell on 2010/01/26 07:33:05
s: moz2-linux-slave25

TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | test failed (with xpcshell return code: 0), see following log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
*** EM_LOG *** Item Installed via directory addition to Install Location: app-global Item ID: {972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** EM_LOG *** Item Installed/Upgraded at Install Location: app-global Item ID: {972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** EM_LOG *** ... success, item installed but is not compatible
TEST-PASS | /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 49] [xpconnect wrapped nsIUpdateItem] != null
TEST-PASS | /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 53] true == true
TEST-PASS | /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 54] true == true
TEST-PASS | /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 55] true == true
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | false == true - See following stack:
JS frame :: /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/head.js :: do_throw :: line 202
JS frame :: /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_eq :: line 232
JS frame :: /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_true :: line 244
JS frame :: /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js :: run_test :: line 62
JS frame :: /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/head.js :: _execute_test :: line 130
JS frame :: -e :: <TOP_LEVEL> :: line 1
TEST-INFO | (xpcshell/head.js) | exiting test

  <<<<<<<

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264552658.1264553628.6976.gz
OS X 10.5.2 mozilla-central opt test xpcshell on 2010/01/26 16:37:38
s: moz2-darwin9-slave11

TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | test failed (with xpcshell return code: 0), see following log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
*** EM_LOG *** Item Installed via directory addition to Install Location: app-global Item ID: {972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** EM_LOG *** Item Installed/Upgraded at Install Location: app-global Item ID: {972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** EM_LOG *** ... success, item installed but is not compatible
TEST-PASS | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 49] [xpconnect wrapped nsIUpdateItem] != null
TEST-PASS | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 53] true == true
TEST-PASS | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 54] true == true
TEST-PASS | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 55] true == true
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | false == true - See following stack:
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/head.js :: do_throw :: line 202
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_eq :: line 232
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_true :: line 244
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js :: run_test :: line 62
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/head.js :: _execute_test :: line 130
JS frame :: -e :: <TOP_LEVEL> :: line 1
TEST-INFO | (xpcshell/head.js) | exiting test

  <<<<<<<
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264554493.1264556204.4690.gz
Linux mozilla-central opt test xpcshell on 2010/01/26 17:08:13
s: moz2-linux-slave15
No idea why this test could ever fail randomly so lets see what values we're actually getting.
Duplicate of this bug: 542466
Summary: Intermittent failure in test_bug541420.js | false == true → Intermittent failure in test_bug541420.js | File should have been executable, permissions were 644
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265051360.1265053431.19115.gz
OS X 10.5.2 mozilla-central opt test xpcshell on 2010/02/01 11:09:20
s: moz2-darwin9-slave11

TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | test failed (with xpcshell return code: 0), see following log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
*** EM_LOG *** Item Installed via directory addition to Install Location: app-global Item ID: {972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** EM_LOG *** Item Installed/Upgraded at Install Location: app-global Item ID: {972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** EM_LOG *** ... success, item installed but is not compatible
TEST-PASS | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 49] [xpconnect wrapped nsIUpdateItem] != null
TEST-PASS | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 53] true == true
TEST-PASS | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 54] true == true
TEST-PASS | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | [run_test : 55] true == true
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js | false == true - See following stack:
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/head.js :: do_throw :: line 202
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_eq :: line 232
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_true :: line 244
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/tests/test_extensionmanager/unit/test_bug541420.js :: run_test :: line 62
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-xpcshell/build/xpcshell/head.js :: _execute_test :: line 130
JS frame :: -e :: <TOP_LEVEL> :: line 1
TEST-INFO | (xpcshell/head.js) | exiting test

  <<<<<<<
Closing as this doesn't seem to have come up again.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.